Xion Audio Player

Skins and cpu usage

Skinning Questions, Suggestions and Ideas

Postby azeo » May 26th, 2011, 12:45 am

First of all, I'm most definately new here, and I thank anyone who can answer this question, or better, solve it.

Ok, as a fun exercise with my daughter, we did a relatively simple skin. It has nothing animated and checks in at only 95k in the zip (xsf) format. Bt comparison, one of the downloadable skins on this site, retrospect, checks in at near 2M in the zip (xsf) format, and comes with ample animation.

How is it, then, that my simple skin will chew up a consisten 10-12 in the cpu usage column of task manager when the player is in the stop mode?
The animations are running in the retrospect skin, and after 30 seconds of watching the task manager, xion cpu usage never topped 5.

As a third point of reference, the default skin, in stop mode goes to 0 cpu and stays there.

I have used my skin in *.psd format, in *.zip format, and in *.xsf format. I have loaded the skin after xion starts, restarted xion with the new skin, and even restarted my computer to restart xion. Always using 5 times the cpu power of a highly animated skin, and infinitely more than the default. WHY?
azeo
Xion Supporter
 
Posts: 2
Joined: May 25th, 2011, 11:45 pm

Postby SLoB » May 26th, 2011, 2:49 am

Hi azeo, welcome to the Xion forum :)

Can you post the psd?
I have an animated skin I'm working on and in pause/stop mode where there are animations cpu is at 0.
Also what processor have you got? And how many other processes are running and what OS. What is the GDI object count (add as column in task manager) (should be small considering the filesize)
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby azeo » May 26th, 2011, 4:48 am

Because my original submission had to go through a screening, and because I got sidetracked, I managed to fix the trouble, but not identify its cause prior to seeing your reply.

For the record, though, I had NO programs running alongside xion, and was simply watching the cpu usage column in task manager where the reading was jumping from 5 to 35, translated as 25%+ cpu consumption at times. (windows 7, at 2% usage max. for task manager to run)

Anyway, all I did, was copy/paste each layer from the original laggy skin image to a fresh blank, starting at the logical "bottom" and working my way upwards. Also, as I got more proficient with the gimp interface, I had fewer unwanted "undo" commands to do. I can't say whether my original stack sequencing made a problem for the xion execution of the layers, or if I managed to create some kind of an image show/hide loop or what.

Being a scientist (formally educated in chem, but teach jr hi and HS now) I tested other theories, running the image on both vista and XP machines with exactly the same laggy results.

The new stack runs at 0-1 now, in play mode, with scrolls and visualizations on all 3 machines. Dunno.

Thanks for your reply though.
azeo
Xion Supporter
 
Posts: 2
Joined: May 25th, 2011, 11:45 pm

Postby logokas » May 27th, 2011, 2:21 am

Things that affect CPU usage:

-Any sort of smoothing of fonts, anywhere
-Large visualizations
-The rare chance that some functions are designed unoptimally. This is not the skins' fault.

Cliff said this before, all the rendering is done in software, hence it's purely CPU. It is also the sole reason i never finished any fullscreen 'party mode' skins. The drop in FPS is just too massive.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 667
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Return to General Skin Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron