Xion Audio Player

[fixed: 126] States not being saved

Discuss potential bugs with other users or try to find out a solution to an existing bug

Postby SLoB » May 29th, 2010, 10:33 pm

Cliff, not sure what's going on with this.

In my Abducted skin the save_state or svst is not working anymore on animation layers.

animation animtype(0) id(lcdclr) delay(1) fadebetween save_state
or
animation animtype(0) id(lcdclr) delay(1) fadebetween svst

This for example used to work in previous builds but no longer works in 1.25, a savestate file is being created when the states are changed.

This is on XP.

Thanks to Shadeclan for letting me know it didn't save states. :)
Also not sure on how many other skins are affected that use savestate?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » November 2nd, 2010, 1:07 am

SLoB Wrote:Cliff, not sure what's going on with this.

In my Abducted skin the save_state or svst is not working anymore on animation layers.

animation animtype(0) id(lcdclr) delay(1) fadebetween save_state
or
animation animtype(0) id(lcdclr) delay(1) fadebetween svst

This for example used to work in previous builds but no longer works in 1.25, a savestate file is being created when the states are changed.

This is on XP.

Thanks to Shadeclan for letting me know it didn't save states. :)
Also not sure on how many other skins are affected that use savestate?


Thanks for the report, I finally got a chance to fix this. Look out for build 126.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Return to Bugs (Release Build)

Who is online

Users browsing this forum: No registered users and 1 guest