Xion Audio Player

Bug Report For Build 150

Discuss potential bugs with other users or try to find out a solution to an existing bug

Postby Pedobear » April 8th, 2013, 4:19 pm

1st one I've found is the playlist menu buttons being unresponsive (File, Edit, View, Add, Remove, Control). Does not always work when clicked.

2nd on I've found is unresponsive hot key's. There are "2" Toggle Main Window options (one of them opens the equalizer and the other does nothing). The actual Toggle Equalizer opens/closes the configuration window.

If you guys find any, please do post them :)
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby Lance » April 8th, 2013, 5:40 pm

Pedobear Wrote:1st one I've found is the playlist menu buttons being unresponsive (File, Edit, View, Add, Remove, Control). Does not always work when clicked.


Ooof, good catch! I made last minute tweaks to the menu and forgot to add passthrough to the label text again. That'll be sorted ASAP. :)
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby Pedobear » April 8th, 2013, 6:52 pm

Lance Wrote:
Pedobear Wrote:1st one I've found is the playlist menu buttons being unresponsive (File, Edit, View, Add, Remove, Control). Does not always work when clicked.


Ooof, good catch! I made last minute tweaks to the menu and forgot to add passthrough to the label text again. That'll be sorted ASAP. :)


Thanks :) and np!
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby SLoB » April 8th, 2013, 10:06 pm

Did the colour hue get added to the playlist background pixel in the end Cliff?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Lance » April 9th, 2013, 10:48 am

SLoB Wrote:Did the colour hue get added to the playlist background pixel in the end Cliff?


It half works at the moment. Just tested with Cliff and it does apply color but the PL doesn't update itself. Should be fixed in the next builllld.
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby regener8ed » April 9th, 2013, 2:17 pm

i have some indi_ objects on layers that use id() and svst (they are on a skin area that i aclahide/aclashow and i want to remember state when switching modes). they don't work until i toggle the layers to hide/show and then they work again, but i have to do this every time i switch the skin.
if the indicator state is already on when i switch the skin, it seems to work fine -- it's only for objects which have the state become true AFTER the skin is loaded that they don't appear to work until i hide/show the layers again.

was working fine in the alpha build...


[EDIT]
okay, it's definitely tied to svst, but limited to things that use indi_. tested via direct layer and group assignments. tried with both aclaswch and aclahide/show combinations. tried with svst and save_state.
always the same behavior (but things work fine if svst is removed.)
Image
regener8ed
Xion Supporter
 
Posts: 82
Joined: September 14th, 2010, 7:29 am
Location: Varies Greatly

Postby Pedobear » April 11th, 2013, 3:51 am

Another bug to report. When you shut down your computer while xion is playing a song etc. all of your settings will reset to default when you boot up and start xion (this includes playlist size, hotkeys etc.)
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby SLoB » April 12th, 2013, 12:52 am

moved thread to bugs (release build)

Also found a bug with svst on slider bit when saving with a hue gradient :( As the colours of the gradient merge towards the outer edges, the sliderbit loses its proper saved position when the skin is refreshed and also changes colour from previous set one (as the position has changed).

and valuefrom needs adding to site help keyword section ;)
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby SLoB » April 12th, 2013, 5:00 am

Xion crashes when resizing the playlist after colour change using the same colour/transparency of the main skin hue (as noted above pl bg doesn't yet change colour)
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby SLoB » April 12th, 2013, 5:14 am

playlist edges still allow resize :(
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Lance » April 12th, 2013, 5:39 am

SLoB Wrote:playlist edges still allow resize :(


To be honest the edge keyword a bit unnecessary anyway since you can tile in any direction using anchors. Anchors + tile does everything edge does and then some.
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby Lance » April 12th, 2013, 5:46 am

SLoB Wrote:Xion crashes when resizing the playlist after colour change using the same colour/transparency of the main skin hue

Cliff, didn't you fix this already? When you added "There's a bug in the latest Xion skin on the Playlist. Because of the resizing, the colorize function fails and actually overwrites memory." to your Done list, I figured that was the exact same thing as my "May have to send you the skin for this. I have the PL menus working with hue now, but when the PL is resized over a certain width, attempting to alter the hue crashes xion. At small-ish sizes it works fine though. Lemme know if you need the skin to fix." bug.

Both are in your Done list. What's more, I don't have this problem anymore, it's super stable even when resized across dual screens. Slob, is this the same thing you're encountering?

SLoB Wrote:(as noted above pl bg doesn't yet change colour)

I answered this above already :)
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby SLoB » April 12th, 2013, 7:20 am

Thats why i put noted as above cos I already knew from your post Lance ;)

The bug I'm having with crashing is by setting the hue on main skin (or within the slider on the pl) with pl open and pl is changing colour (except the background at this point in time/build) then resize the pl and it crashes.

To clarify my point with the edge keyword is that it doesn't stop the resizer kicking in, which it's supposed to. I've got a complete layer above the border in a corner to test, even setting it to moveable doesn't make the resizer function change.
Edge should block resize functionality as described in the keyword description.

I could try it with an anchor (although no tiling for edge other than top, left,right,bottom), however I suspect the same issue may occur, I'll test that, however edge is still broken.
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby SLoB » April 12th, 2013, 9:40 pm

Just checked the default skin hue on refresh and that's working right, so it's just the horizontal one tintrl that needs fixing, no-one was doing a horizontal one during betas, which explains why it was out of the loop.

Just tested anchors and changing edge to anchor makes no difference, border functionality is still activated :(
It's particularly noticeable underneath buttons on the pl such as close, minimise, plmenu.

Also reverse order of resizing pl first, then changing hue crashes xion
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Lance » April 13th, 2013, 4:06 am

SLoB Wrote:Just tested anchors and changing edge to anchor makes no difference, border functionality is still activated :(
It's particularly noticeable underneath buttons on the pl such as close, minimise, plmenu.


This is both interesting and confusing. Could you please upload a psd to look at? I can't replicate it here.
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England
Next

Return to Bugs (Release Build)

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron