Xion Audio Player

Xion 1.0 build 63 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » October 26th, 2006, 10:37 pm

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b63.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b63.exe

Changelist:
  • Add fixes so that layersets are only setup as animation sets if they hold the keyword

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.

NOTE: This is a minor release to fix the problems with the skin system that were pretty much crippling any skins using advanced features or layersets. I will have to go over the bugs reported for the last build still, so feel free to post again about the bug, but otherwise I should pick it up from the last build.

Let me know if there is still anyone with skins not working after this build.

Enjoy!

Cliff :)
Last edited by Cliff Cawley on January 11th, 2008, 11:23 am, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby NickMikh » October 27th, 2006, 11:51 pm

MiPod

Volume animation behaves strange, it is on the bottom of the skin. It shows frame 10 (lenght is 11) and the right frame at the same moment, after I make volume according to the frame (10), it behaves correctly.
BTW, what about a hiding layer? It would be nice.
User avatar
NickMikh
Xion Supporter
 
Posts: 8
Joined: September 11th, 2006, 1:38 pm
Location: Russia

Postby Ganoderma » October 28th, 2006, 8:44 pm

in the mini WMP11 skin, the play/pause button wont show up.

didnt find anything else jet...
User avatar
Ganoderma
Xion Supporter
 
Posts: 11
Joined: October 28th, 2006, 8:38 pm

Postby pickle » October 29th, 2006, 11:55 am

2 things related to tooltips:

  1. It seems that if the tt keyword is after an id keyword, the tooltip adopts the text of the id.
  2. When I tried to test that theory on multiple layers, I managed to crash Xion without fail & also without any notification (such as Windows saying the program needs to shut down).

    A PSD file that shows what I'm talking about is available here. To observe the behaviour I'm talking about, click the little triangle above the song title.
User avatar
pickle
Xion Admirer
 
Posts: 180
Joined: September 9th, 2006, 3:56 pm

Postby Ganoderma » October 29th, 2006, 11:44 pm

i found out more about the mini WMP skin, it seems that the play button does work, but the pause not.

so it doesnt show when its playing but only if xion is paused or stopped.
Also the Playlist, random and repeat buttons wont go 'glow' if turned on.
The X button (close) doesnt work either, if i click it my pc gets very slow and fasten when i close xion trough the system icon.

EDIT//
i mean the media player 11 skin.
also with the above post.
User avatar
Ganoderma
Xion Supporter
 
Posts: 11
Joined: October 28th, 2006, 8:38 pm

Postby Cliff Cawley » October 30th, 2006, 7:03 am

Thanks for the reports guys!

I'll check this out tonight when I get home :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » November 1st, 2006, 12:29 am

progress slider doesnt work on streamed mp3s even if most of mp3 played and buffered 100%
surely if its played part of the song it should be possible to slide back?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby pickle » November 1st, 2006, 6:39 am

SLoB Wrote:progress slider doesnt work on streamed mp3s even if most of mp3 played and buffered 100%
surely if its played part of the song it should be possible to slide back?


Not to the best of my knowledge. Streamed media is read instantly, then discarded. If you've got a 128kbps stream, then every second Xion downloads 128kb, plays it, then discards it. This is one of the bonuses of streamed media - a local copy isn't necessarily left on the user's (ie: you) computer.

If you want to record streams, I'd recommend StreamRipper.
User avatar
pickle
Xion Admirer
 
Posts: 180
Joined: September 9th, 2006, 3:56 pm

Postby SLoB » November 1st, 2006, 7:57 am

its not quite a stream just a basic url to an mp3 which is buffered 100%, which, to all intents and purposes has downloaded the track into tmp space/mem
perhaps i should have rephrased the topic

if you have a url for an mp3 it will download the song to the player, if you look at winamp for example, that allows you to seek back and forth of the content that is downloaded so far, once its all downloaded its free to seek from start to end

i kno wot you mean for example on a radio station which is purely streamed and i would not expect ther to have seek functionality
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Nightbreed » November 1st, 2006, 3:54 pm

I'm not sure of the issue with the MiniWmp11 skin. All buttons show fine for me. Is anyone else seeing this problem? I have no way to troubleshoot this atm.
If it aint broke, fix it anyway. You may do it better.
User avatar
Nightbreed
Xion Supporter
 
Posts: 61
Joined: September 26th, 2006, 1:43 pm
Location: Philadelphia, PA

Postby SLoB » November 1st, 2006, 11:29 pm

mini WMP11 skin
--------------------
buttons work fine except stopindi/stop button backround is not shown just the white square and not the blue button

seek should be made thicker as its only a few pixels thick and not very user friendly

get the same issue with random/repeat not showing too

build 63
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby SLoB » November 2nd, 2006, 5:02 am

hmm, started up Xion, opened up pl and doubleclicked on a song, song starts but no progress sliderbit, was ok on skin reload tho
is F5 refresh coming soon?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Ganoderma » November 2nd, 2006, 8:56 pm

well, dont use the miniWMP skin, but the WMP11 skin... ;)

playing works fine only some buttons dont appear how they should ;)
User avatar
Ganoderma
Xion Supporter
 
Posts: 11
Joined: October 28th, 2006, 8:38 pm

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 5 guests

cron