Xion Audio Player

Xion 1.0 build 64 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby pickle » December 14th, 2006, 2:17 pm

The skin was more of a proof-of-concept idea than anything. I wanted a quick minimal skin that was basically just text, but would look legible on any background.

I fully realize that you consider 9 stacked text layers obscene. I thought that might be the case, but I wasn't sure. Consider it a stress test ;)
User avatar
pickle
Xion Admirer
 
Posts: 180
Joined: September 9th, 2006, 3:56 pm

Postby Cliff Cawley » December 15th, 2006, 7:14 am

pickle Wrote:The skin was more of a proof-of-concept idea than anything. I wanted a quick minimal skin that was basically just text, but would look legible on any background.

I fully realize that you consider 9 stacked text layers obscene. I thought that might be the case, but I wasn't sure. Consider it a stress test ;)


Haha, no worries, I've known for a while now that the text isn't the most optimized piece of code, so this is forcing me to update and it and make it faster :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » December 15th, 2006, 7:34 am

cool, any chance your fixing that shifting bug if text is centered cliff which i mentioned near the bottom of pg1?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » December 15th, 2006, 5:44 pm

SLoB Wrote:cool, any chance your fixing that shifting bug if text is centered cliff which i mentioned near the bottom of pg1?


I'll definitely be looking into it. Spare time at the moment is a little hard to come by, hence the slow updates, but I do intend to release a new build soon with some changes I've been working on.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby pickle » December 21st, 2006, 4:32 am

I think this may be related to the volume animation bug mentioned earlier. My particular problem is with the netbuffer animation.

Long story short, I've got an animation set with 5 layers. The first layer is always being displayed, even while the other 4 get cycled through.

You can see what I'm talking about in this sample skin. Make sure you listen to radio to see what I'm talking about.

The blue dot is on the first layer in the set. The marks around the circle are in subsequent layers. The subsequent layers behave as expected, but that blasted first layer keeps sticking around.
User avatar
pickle
Xion Admirer
 
Posts: 180
Joined: September 9th, 2006, 3:56 pm

Postby Cliff Cawley » December 30th, 2006, 4:20 pm

NickMikh Wrote:Image
Here is the image of the error (bottom, in the middle)

And here is the skin (Mipod) I use beta 64.


I've fixed this for build 65. By the way, I love the fake battery meter you put and how it slowly drains! :wink: (I only noticed it because I was dissecting your skin!)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » December 30th, 2006, 4:31 pm

pickle Wrote:The skin was more of a proof-of-concept idea than anything. I wanted a quick minimal skin that was basically just text, but would look legible on any background.

I fully realize that you consider 9 stacked text layers obscene. I thought that might be the case, but I wasn't sure. Consider it a stress test ;)


Optimized! I've now optimized this to a point where it *may* use sometimes 1% of the CPU but mostly it sticks around 0. The problem was that because each of the text layers was slightly offset, it was generating a new dirty rectangle, and for each rectangle, it was drawing each of the text layers again as each of them had parts in that dirty rectangle.

Basically this ended up redrawing about 81 times! (9 layers of text, each with their own dirty rectangle!). I've always known that the overdraw caused by the dirty rectangles was a slow point but didn't have the time to fix it.

You'll be happy to know that your skin now only draws with 1 dirty rectangle after Xion applies a bunch of optimizations in order to completely remove any overdraw!

I also optimized the Text drawing so that the font is created once instead of every frame as it used to be.

You will be able to test this out in build 65.

Other users may notice speed improvements on their systems as well, most likely you will notice improvements on older systems, rather than newer systems.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » December 30th, 2006, 8:57 pm

SLoB Wrote:has the centered font movement skipping if songname longer than width while moving from right to left been fixed yet?
cant remember when it was raised
its fine if left alligned but no good if u want to center text if the songname is best suited in the middle for shorter names


Yes, just fixed this for build 65, both Center and Right aligned text are now fixed.

SLoB Wrote:song title stays on Buffered (100%) if getting mp3 from a site and doesnt change to actual song title
playlist also has same text rather than songtitle
infact none of the id info is in the songinfo screen and i know there is some cos its a few of my cover songs

on playlist repeat the songtitle appears in both songticker and playlist entry if song still there altho still no id tag info from playlist viewsonginfo


I've now changed this so that it changes to the Song filename until it is able to read the Tags. There is a bug in the latest version of the sound engine that I'm using that no longer loads .mp3 files from urls, so hopefully they will fix that soon, but other than that it should work for 65.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » December 30th, 2006, 9:02 pm

SLoB Wrote:transnetbuffer layer stays active/pulsates even though song in playlist is on hdd

for example if you have a mix of 2/3 tracks a few on hdd and a few urls
on buffer the netransbuffer layer kicks in nicely but then stays activish during the song even tho buffered 100%, if you click on next track which is say on hdd the transnetbuffer layer still stays active even tho there is nothing to buffer?


By default it was setting the buffer status to 100% when it was not a netstream (i.e. hdd), I've changed this to 0% for build 65 so that it no longer displays and should fix the problem of listening to a netstream and then a hdd stream.

As for the staying active after a song is buffered, I'm happy to leave it like that since it is a net stream. The netstream indicator is more for net radio streams, rather than playing mp3's from urls, as you will see if you listen to a stream from www.shoutcast.com

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » December 30th, 2006, 9:45 pm

SLoB Wrote:paste into address text box for playlist doesnt use ctl+v, its not fixed in 64 but might be in 65?


This is now also fixed for build 65

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » December 30th, 2006, 10:35 pm

good work Cliff :) amazing wot a xmas break does heheh :)
the text optimisation should be cool, it will allow for a lot more possibilities for text manipulation for effects, n1 :)
yep nettransbuffer logic sound
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby SLoB » December 31st, 2006, 12:34 am

Cliff
are you putting out version 0.4.6.0 of the fmodex.dll with build 65?
i've been using it for a week or so now with no probs, it still didnt fix the playlist issue tho of Xion crashing if url song removed from playlist but still visible in the songticker then played which i mentioned in an above post

also is it possible to add double click on the songticker to open up id tag info screen?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » December 31st, 2006, 1:00 am

SLoB Wrote:are you putting out version 0.4.6.0 of the fmodex.dll with build 65?


Yes, in fact most likely 4.06.01, although I've found a bug with it and have notified them (it doesn't play mp3's from urls at all).

SLoB Wrote:i've been using it for a week or so now with no probs, it still didnt fix the playlist issue tho of Xion crashing if url song removed from playlist but still visible in the songticker then played which i mentioned in an above post


Ok, its possible this is my fault, could you give me the steps to reproduce (along with the URL you are using) ? If you already stated this, I'm sorry, its 1am and I couldn't find it :(

SLoB Wrote:also is it possible to add double click on the songticker to open up id tag info screen?


Sure, sounds like a good request and not too difficult.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » December 31st, 2006, 1:35 am

SLoB Wrote:is it possible to add double click on the songticker to open up id tag info screen?


Added and ready to go for build 65.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » December 31st, 2006, 2:29 am

ok startup xion
open playlist
add url http://www.slob.org.uk/trax/FoolForYaLovin.mp3 any url to an mp3 will do tho but if ya like a bit of whitesnake ;)

play mp3
delete mp3 from playlist
stop mp3
then goto play it again and xion crashes

happens everytime you do that, just checked that also happens if an mp3 is from the hdd and removed in the same manner xion crashes
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK
PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest