Xion Audio Player

Xion 1.0 build 78 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » March 21st, 2007, 8:02 pm

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download Installer Version:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b78.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b78.exe

Download Portable Device Version:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b78.zip
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b78.zip

Changelist:
  • Fix crashes when playing .cda tracks
  • Add 'Get More Skins!' button to the Skin Browser
  • Add Comment reading back in
  • If the visualization that is drawn on the skin has the 'Random color' disabled, it will use whatever colour the skin author has chosen for the visualization layer
  • Don't fade the _Down layer in, only out, so that you get to actually see the _Down if you click quickly
  • Add the ability to remember the selection and the top index when applying/removing filters to the playlist

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.

Seems like we are almost there! I think this builds should now fix the rest of the existing crash issues that users have been experiencing! Please test this and let me know, because if this build is good, I'm going to do a final Gold build and release it to the public!

Enjoy!

Cliff :)
Last edited by Cliff Cawley on January 11th, 2008, 11:26 am, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » March 21st, 2007, 11:25 pm

sweet :)
no cd crashes :)

better start getting that feature request list filled for after the next full release ;) heh :lol:
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » March 21st, 2007, 11:30 pm

SLoB Wrote:sweet :)
no cd crashes :)

better start getting that feature request list filled for after the next full release ;) heh :lol:


Haha, oh it already is full ;)

There are plenty that I haven't implemented for this release that are still active in the forums :P

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby KEV-O » March 22nd, 2007, 2:01 am

I'd give ya three thumbs up if I had 'em!
User avatar
KEV-O
Xion Admirer
 
Posts: 246
Joined: October 15th, 2006, 12:47 pm
Location: Kokomo, Indiana

Postby djinn2 » March 22nd, 2007, 3:16 am

Dunno if its a bug or just the way this skin works but the progress display toggle on Airport doesn't work any more. It was fine on build 77.
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby simon » March 22nd, 2007, 6:00 am

Hi Cliff!, how ya doing?

I just wanted you to know about the submission of Xion to TPFC Xion 1.0 build 76 Beta (development)
Image
K-Ninja! Fast, Sleek and Effective!
simon
Xion Supporter
 
Posts: 8
Joined: March 2nd, 2007, 9:46 pm

Postby Cliff Cawley » March 22nd, 2007, 6:48 am

simon Wrote:Hi Cliff!, how ya doing?

I just wanted you to know about the submission of Xion to TPFC Xion 1.0 build 76 Beta (development)


Hi Simon,

That's cool as long as they understand its a beta release ;)

The Public release will be coming soon, when I'm happy with the stability of Xion.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » March 22nd, 2007, 6:48 am

djinn2 Wrote:Dunno if its a bug or just the way this skin works but the progress display toggle on Airport doesn't work any more. It was fine on build 77.


Hmm, will have a look at this tonight when I get home and let you know, thanks for the report! :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby simon » March 22nd, 2007, 6:51 am

Cliff Cawley Wrote:
simon Wrote:Hi Cliff!, how ya doing?

I just wanted you to know about the submission of Xion to TPFC Xion 1.0 build 76 Beta (development)


Hi Simon,

That's cool as long as they understand its a beta release ;)

The Public release will be coming soon, when I'm happy with the stability of Xion.

Cliff :)


sure Cliff! no problem! :wink:
Image
K-Ninja! Fast, Sleek and Effective!
simon
Xion Supporter
 
Posts: 8
Joined: March 2nd, 2007, 9:46 pm

Postby fpens » March 22nd, 2007, 7:54 am

Hi!

I don't know what happened, although I assume it's related to the DLL you replaced, but...

In the last few builds the sound quality has gone completely down the drain. It's now so bad that I've gone back to Winamp - just can't take the lousy sound.

Otherwise, I love the prog and had planned to keep using it.
Cheers,
Norman
fpens
Xion Supporter
 
Posts: 1
Joined: March 21st, 2007, 10:37 am

Postby SLoB » March 22nd, 2007, 8:39 am

hmm, ive noticed a small difference on a few old mp3s (which the levels were already clipping) but nothing else on most, altho i'm using sharkoon 5.1 headphones here and all other tracks sound just as good

think both FModex and BASS libraries are used depending on which format is playing, AAC/MP4/CD deffo mainly for BASS, not sure which library is playing mp3, Cliff will be able to clear that up

your best option is to post a few of those tracks where you think the degredation seems worse to see if anything can be fixed, altho if the tracks are not 100% in the first place then no dll is going to be able to fix it, are you using normalisation on tracks in winamp and or preventing clipping or using gain?

do they sound worse even if the eq is turned off?
i dont use the eq in any media player

Cliff is there any normalisation routines that can be added/configured?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » March 22nd, 2007, 9:27 am

fpens Wrote:Hi!

I don't know what happened, although I assume it's related to the DLL you replaced, but...

In the last few builds the sound quality has gone completely down the drain. It's now so bad that I've gone back to Winamp - just can't take the lousy sound.

Otherwise, I love the prog and had planned to keep using it.
Cheers,
Norman


I have recently changes from using FMODEx to BASS. I myself can hear that BASS sounds worse than FMODEx, but most users have said that BASS sounds better. So I'm really not sure anymore.

BASS supports more sound formats, but for me sounds worse, but for people like SLoB, he can hardly hear the difference.

It might be something to do with Sound drivers. Have you updated your drivers recently?

I exclusively use BASS, not a mix of the too at the moment.

Also, as another check, are you using the Equalizer? If so, try disabling it, or checking to make sure it is disabled. Its possible this could be affecting the quality.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » March 22nd, 2007, 9:03 pm

djinn2 Wrote:Dunno if its a bug or just the way this skin works but the progress display toggle on Airport doesn't work any more. It was fine on build 77.


The problem is that the normal layer is missing the params that the _over layer has, so now that the _down layer gets triggered so fast, the _over layer gets skipped.

The airport skin has no _down layer, so the _normal layer is used instead. a-RIP just needs to update the skin to account for this and it will work as before :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby djinn2 » March 23rd, 2007, 12:49 am

I thought that might be it.

Anyway I had a crash of sorts earlier similar to the long playlist bug from before. There was no error message but Xion had just stopped and wouldn't play anything at all. The track info was loading in though.

I presume that whatever it was will still be present in build 79.
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby SLoB » March 23rd, 2007, 2:36 am

check eventvwr --> application
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK
Next

Return to Beta Builds

Who is online

Users browsing this forum: Google Adsense [Bot] and 4 guests

cron