Xion Audio Player

Xion 1.0 build 91 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby ALAS » February 12th, 2008, 6:28 am

xonenine wrote:I guess I spoke too soon. Now Xion won't let me drag .psd files to the player, I can only add them by zipping and placing in the interface directory. Can anyone help w/ this?



it is not necessary to zip it, it´s only important to have it in the interface folder, so I just save my psd´s there when I work on them...

(nevertheless this might be a bug)

another good practice for faster working is, keep Xion running, make some changes in the psd save it and press F5, then Xion will reload the current skin (with your changes) and you can easily and fast check your changes...
User avatar
ALAS
Xion Fan
 
Posts: 256
Joined: March 12th, 2007, 3:26 am

Postby ALAS » February 12th, 2008, 6:43 am

Cliff, sent it again, but I guess it didn´t work again...

"your skin has been .... successfully" but before there was a lot of time without traffic, like yesterday...
User avatar
ALAS
Xion Fan
 
Posts: 256
Joined: March 12th, 2007, 3:26 am

Postby SLoB » February 12th, 2008, 7:09 am

prolly best to ul to yer ftp and pm the link ALAS
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » February 12th, 2008, 7:30 am

ALAS wrote:
Cliff Cawley wrote:
ALAS wrote:I send an example to you Cliff for reproducing it (ggcFlip-where I deleted everything that has nothing to do with the problem)


Did you send the example? I haven't received it yet...

Cliff :)


yes, twice, because I wasn´t shure if it worked well ....

obviously it didn´t... will do again later... :)


Just checked again and the email is there now! I will look at it within the next 10 hours or so (After work)

SLoB wrote:Cliff
Have you put the new version up with this fix?


No not yet, waiting for more reports of bugs. Will probably do another build soon though.

Cliff :)
Last edited by Cliff Cawley on February 12th, 2008, 7:32 am, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby ALAS » February 12th, 2008, 7:32 am

SLoB wrote:prolly best to ul to yer ftp and pm the link ALAS


did another upload (from my non vista PC), if it didn´t work again I´ll do what you suggested (tomorrow, today computers don´t like me, not only with Xion)
User avatar
ALAS
Xion Fan
 
Posts: 256
Joined: March 12th, 2007, 3:26 am

Postby Cliff Cawley » February 12th, 2008, 7:34 am

ALAS wrote:
SLoB wrote:prolly best to ul to yer ftp and pm the link ALAS


did another upload (from my non vista PC), if it didn´t work again I´ll do what you suggested (tomorrow, today computers don´t like me, not only with Xion)


Well I got your submission. Strange, its dated 10th Feb (its 12th today here). I wonder if my email is having problems after my server was down over the weekend :(

I'm probably going to get like 100 emails from ALAS now, with 100 copies of the skin! :P

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » February 12th, 2008, 7:37 am

xonenine wrote:I guess I spoke too soon. Now Xion won't let me drag .psd files to the player, I can only add them by zipping and placing in the interface directory. Can anyone help w/ this?

I'm also getting other crashes now, loss of sound requiring reinstall, (the prog is still running, vis is still working, just no sound) and inactive buttons and indicators in the right click menu. This seemed to be precipitated by dragging the skins.

Thanks,
xonenine :cry:


Not sure what's going on here, the drag and drop of psd's is working on this end. Did you check the obvious things such as volume? Also check the files you're playing, is it a local file or radio? Do some files play and others don't? If some don't, then send me the one that doesn't!

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby xonenine » February 12th, 2008, 10:14 am

This certainly counts as one of the stranger things I've seen. After every install, clean and over, the player worked. After exiting Xion the player wouldnt play, while my others did. Much to my chagrin, I finally noticed that after the install and exit, upon restart my Xion was defaulting to full left balance, volume off. No other progs or volumes were affected, so I never noticed it until I ran through all my Xion configure tabs, looking for the obvious. Once reset, the sliders are ok, I've since restarted multiple times, dragged (and hot keyed, thanks) psds and zips, with no further issues. I just wish I noticed the sliders earlier.

Thanks Cliff :oops:
User avatar
xonenine
Xion Freak
 
Posts: 870
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby Cliff Cawley » February 12th, 2008, 11:50 am

xonenine wrote:This certainly counts as one of the stranger things I've seen. After every install, clean and over, the player worked. After exiting Xion the player wouldnt play, while my others did. Much to my chagrin, I finally noticed that after the install and exit, upon restart my Xion was defaulting to full left balance, volume off. No other progs or volumes were affected, so I never noticed it until I ran through all my Xion configure tabs, looking for the obvious. Once reset, the sliders are ok, I've since restarted multiple times, dragged (and hot keyed, thanks) psds and zips, with no further issues. I just wish I noticed the sliders earlier.

Thanks Cliff :oops:


Hehe, no worries, I thought it might have been something as simple as that. Good to hear you got it all sorted now :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » February 12th, 2008, 7:04 pm

ALAS wrote:
SLoB wrote:prolly best to ul to yer ftp and pm the link ALAS


did another upload (from my non vista PC), if it didn´t work again I´ll do what you suggested (tomorrow, today computers don´t like me, not only with Xion)


Sweet, got your skin (4 times! heheh!) and have fixed the problem for the next build :)

I think that's all the issues now, so I'll do a new build soon.

Thanks again for finding this one!

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby zeolyte » February 12th, 2008, 8:14 pm

hi Cliff.. I'm modifying AgSio skin for this build... all visualisations showed up and animated perfectly except for the xion default vis, none of it showed up
User avatar
zeolyte
Xion Supporter
 
Posts: 25
Joined: August 23rd, 2007, 6:51 pm

Postby ALAS » February 12th, 2008, 8:19 pm

Cliff Cawley wrote:
ALAS wrote:
SLoB wrote:prolly best to ul to yer ftp and pm the link ALAS


did another upload (from my non vista PC), if it didn´t work again I´ll do what you suggested (tomorrow, today computers don´t like me, not only with Xion)


Sweet, got your skin (4 times! heheh!) and have fixed the problem for the next build :)



great! :-) did you have a look also at the Tactual Encapsulated ext. crashing issue, maybe that´s also fixed now?
User avatar
ALAS
Xion Fan
 
Posts: 256
Joined: March 12th, 2007, 3:26 am

Postby Cliff Cawley » February 12th, 2008, 10:27 pm

ALAS wrote:great! :-) did you have a look also at the Tactual Encapsulated ext. crashing issue, maybe that´s also fixed now?


Yup that's fixed now too :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby ALAS » February 13th, 2008, 1:39 am

Cliff Cawley wrote:
ALAS wrote:great! :-) did you have a look also at the Tactual Encapsulated ext. crashing issue, maybe that´s also fixed now?


Yup that's fixed now too :)

Cliff :)


thanks! :-)
User avatar
ALAS
Xion Fan
 
Posts: 256
Joined: March 12th, 2007, 3:26 am

Postby sp3ctum » February 13th, 2008, 4:49 pm

Hi. I just wanted to say that I think it's great that you're all so dedicated to improving Xion. It's never crashed for me, but I'll try my best to help otherwise since I think the player is so good.
While this is a little besides the point, I'd still like to point out that the first download link is broken :oops:
I'm not trying to be a smart ass or anything, but.. yeah. :D
sp3ctum
Xion Supporter
 
Posts: 16
Joined: February 11th, 2008, 7:48 pm
PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest

cron