Xion Audio Player

Xion 1.0 build 103 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » November 9th, 2008, 10:18 pm

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download Installer Version:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b103.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b103.exe

Changelist:
  • Fixed loadinterface calls from skins not working correctly
  • Fixed the flicker on Windows Vista when resizing the Playlist window by removing the WS_EX_COMPOSITED flag and using an alternate method
  • Modified the way that the Playlist window resizes so that it uses a rectangle to show the resize area
  • Fixed a crash when you attempted to install a skin
  • Added the ability to remember which playlist skins were loaded
  • Modified the Skin Browser to automatically load playlist skins into the playlist window

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.


ABOUT THIS BUILD:

Fixes to better clarify the loading of a playlist. Choose it from the skin dialog now and it will properly load in the playlist window instead of the main window

Any questions or bugs related to this build should be posted here only!

Enjoy!

Cliff :)
Last edited by Cliff Cawley on November 19th, 2008, 10:21 pm, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » November 10th, 2008, 4:07 am

Why exactly does the playlist load the default interface onto itself at first launch? It scared the crap out of me the first time.

Anyway, aside from that, it looks like error reporting isn't functioning like you said it would. At least, i'm unable to find out where it stores it's crash logs.

Yay for first person!
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Lance » November 10th, 2008, 4:48 am

Holy noochies, another build already. Alright I'ma download now and give it a whirl. Thanks a bunch dude!

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby Lance » November 10th, 2008, 5:09 am

Alrighty, some imediate things I notice:

1) Save states no longer work, they didn't in 102 either. They used to only not work when opening Xion directly from opening an audio file, but they worked if you loaded Xion from the .exe. Now they don't work at all.

2) Yeah....what logokas said...what's with the playlist loading the default skin into itself? I can't seem to shake it off now that it's happened. Thanks for the heads up though logokas, that would have scared the shit outa me too if I wasn't prepared :wink:

3) I'm not sure about the new resize rectangle for the PL...I thought it was much better seeing it resize on-the-fly so to speak. Plus, the rectangle is underneath the PL so you can't even see it when making it smaller. Unless I missed a specific reason for why this was changed, I would personally recommend (or beg, whichever suites you best) that it is returned to how it was :)

I'll post more as they come and I'll try skinning a simple PL to test out it's inner-functions too.

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby Cliff Cawley » November 10th, 2008, 7:47 am

logokas Wrote:Why exactly does the playlist load the default interface onto itself at first launch? It scared the crap out of me the first time.


Hmm, I tried this on a clean install and couldn't reproduce, it was working fine here. I even tried it on a non-clean install. Have you got steps to reproduce?

logokas Wrote:Anyway, aside from that, it looks like error reporting isn't functioning like you said it would. At least, i'm unable to find out where it stores it's crash logs.


If it crashes, it should be automatically allowing you to save/open an email that will attack the log?

Lance Wrote:Save states no longer work, they didn't in 102 either. They used to only not work when opening Xion directly from opening an audio file, but they worked if you loaded Xion from the .exe. Now they don't work at all.


Hmm, I'll need to look into this, thanks for letting me know.

Lance Wrote:I'm not sure about the new resize rectangle for the PL...I thought it was much better seeing it resize on-the-fly so to speak. Plus, the rectangle is underneath the PL so you can't even see it when making it smaller. Unless I missed a specific reason for why this was changed, I would personally recommend (or beg, whichever suites you best) that it is returned to how it was


Unfortunately for now the resize rect will need to stay. There's no other way that I can find to do this that properly works on Vista as well as XP. I'll need to fix the resize rect so that when it shrinks it draws properly over the top, yes.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » November 10th, 2008, 7:52 am

I get no dialogue to send an e-mail. If you're using something like making an Outlook e-mail message then that's not a good idea at all.. Without the program it can't function, plus most people probably don't even use it.

At any rate, no message popup, whatsoever.

As far as Vista goes, what exactly did it do that the resizing feature had to be changed?
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » November 10th, 2008, 8:04 am

logokas Wrote:As far as Vista goes, what exactly did it do that the resizing feature had to be changed?


Constant flickering of the window, not just when resizing. Until I find a solution its back to this type of resizing. I'm assuming its the reason Winamp does the same thing when resizing.

I don't see why its such a big deal though, its not like you spend all your time resizing your playlist window? (Or do you have a confession to make? :P)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » November 10th, 2008, 9:25 am

I must admit that i have a playlist resizing fetish. :<

Haha, not really.

It just looks prettier the other way. And Xion's alot about being pretty y'see.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » November 10th, 2008, 1:23 pm

logokas Wrote:I must admit that i have a playlist resizing fetish. :<

Haha, not really.

It just looks prettier the other way. And Xion's alot about being pretty y'see.


Well it looks prettier how it is now, because before on Vista it looked terrible ;)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby djinn2 » November 11th, 2008, 4:08 am

Everything was working well until I changed the interface and the playlist loaded the main interface psd. It was similar to what OfficerMike07 reported in the version 102 topic. Changing the interface loaded that skin for the playlist too, even the main psd for the default interface was used for the playlist when it was loaded.

I'm pretty sure this wasn't happening on the previous build. Using Windows XP SP3.
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby Lance » November 13th, 2008, 6:27 pm

Just a quick suggestion. Could you allow the snap rectangle to snap to the main player interface, like Winamp and others :) Cheers dude.

EDIT: Oh and once it's snapped, be able to drag them both simultaneously by dragging the main player, again like Winamp :) Cheers!

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby pickle » November 14th, 2008, 7:00 am

I'd really like for the Last.fm plugin to work again.
User avatar
pickle
Xion Admirer
 
Posts: 180
Joined: September 9th, 2006, 3:56 pm

Postby xonenine » November 16th, 2008, 12:38 am

In installing 102 and 103 I've found that leaving the run xion after install box checked causes alot of the skins to go missing. Only a clean install after this occurs will fix it.
I reinstalled from 1.00 clean several times to duplicate this problem and it always occurred. If I uncheck the run xion box, all is well.
I'm on an up to date vista home premium.
thanks Cliff, xonenine.

btw the default skinned playlist resizes without a flicker for me, and looks nice, didnt see it before. :)

Later: Can the playlist window have a choose skin option incorporated?
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby Cliff Cawley » November 18th, 2008, 11:40 pm

pickle Wrote:I'd really like for the Last.fm plugin to work again.


I'll update the Last.FM once I've released this build to the public. The Last.FM should be working fine for build 100, the last released Public build though?

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » November 18th, 2008, 11:42 pm

xonenine Wrote:In installing 102 and 103 I've found that leaving the run xion after install box checked causes alot of the skins to go missing. Only a clean install after this occurs will fix it.
I reinstalled from 1.00 clean several times to duplicate this problem and it always occurred. If I uncheck the run xion box, all is well.
I'm on an up to date vista home premium.
thanks Cliff, xonenine.


Ah thanks, I'll look into this. The install may not be setting the working directory properly.

xonenine Wrote:Can the playlist window have a choose skin option incorporated?


I thought about this but decided against it. So for now there's just one Skin Browser. If you load a playlist skin though it will automatically be loaded in the playlist and not the main window.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 14 guests