Xion Audio Player


General Discussion about Xion Audio Player

Postby Freerun » August 16th, 2013, 5:38 am

I've seen two very old threads like from 2006 about problems with characters.
Was anything done about that? The one about Turkish characters was marked as "fixed in v108" but was Unicode support ever implemented?

I've noticed that Polish special characters aren't supported :cry: :cry: :cry:

I think Unicode should have been implemented before Xion became skinnable^^.
Xion Supporter
Posts: 32
Joined: January 11th, 2013, 3:41 am

Postby logokas » August 16th, 2013, 8:21 am

Unicode IS supported. I should know, I spearheaded that feature, because none of my japanese titled music was showing up proper.

Whatever issues you're having is perhaps a bug relating to polish letters? I'm sure Cliff can shed some light on it.

An example would also help sorting this out quicker.
I shoot and ask questions later.

Take no offense of it.
User avatar
Xion Addict
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Freerun » August 17th, 2013, 11:25 am

Just after I've read your post it came to me that this may be the problem with file format.
I've tested and it turns out that mp3s with Polish letters display properly. It does not work with my m4a files from iTunes.

Polish letters:
ą ć ę ł ń ó ś ź ż

For testing I changed names of both mp3 and m4a files:



I consider this as bug and will post this also in bug section with screenshots.
Xion Supporter
Posts: 32
Joined: January 11th, 2013, 3:41 am

Return to General Xion Discussion

Who is online

Users browsing this forum: No registered users and 4 guests