Xion Audio Player

Xion 1.0 build 65 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » December 31st, 2006, 11:20 am

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b65.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b65.exe

Changelist:
  • Fix crash when using loadinterface with _over
  • Fix animation direction(1) flag not working as it should
  • Fix detection of user values so that extra ( and ) characters are not detected, only the first ( and the last ). This now fixes fonts with ( and ) in their names
  • Fix some issues with focus not getting set correctly. This undoes some changes to do with over images when Xion doesn't have focus, but I would consider that less priority than the focus working
  • Add support for Installing Skins that arn't in the Xion Interface Directory. Will copy there and open after asking for permission from the user
  • Ensure Xion only asks for skin install if you double click the .xsf file and not when you drag and drop or start
  • Fix loading of previews due to working path of helper not being set
  • Fix loading of Interfaces when .psd is added into layername
  • Add complete Font System rework so that it doesn't create the font each frame
  • Add massive optimizations to the dirty rectangle code so that it intelligently creates dirty rectangles that are unique and do not overlap
  • Add more optimizations to the dirty rectangle rendering code to ensure each case is rendered correctly
  • Fix animation not displaying first frame when direction(1) is used
  • Fix Text Scrolling with Centered and Right aligned Text so that it works in the same was as Left aligned Text
  • Once a file is 100% buffered, change its title to the filename, while waiting for tag information
  • Fix crash when copying and pasting nothing
  • Fix message processing order so that windows in focus receive messages first
  • Ensure FLAC files can be added to the playlist
  • Add support for clearing the list and playing songs when dragging and dropping to the player interface or when launching from Windows Explorer
  • Add support for button to show/hide any Library components
  • Add support for double clicking on the Track title and showing the File information for that Track
  • Fix crash when deleting item and trying to select it again when it no longer exists
  • If an error occurs while playing a netstream, change the title text appropriately
  • Add support for indi_equalizer so that you can determine if the Equalizer is on or not
  • Add 'Disable All' button for the Hotkey list so that you can disable all hotkeys

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.

This version features some major changes to the skin rendering system to allow it to run faster and draw more optimally than in previous builds. If you notice strange things happening with your skin not drawing correctly, please let me know, along with a copy of your skin!

Enjoy!

Cliff :)
Last edited by Cliff Cawley on January 11th, 2008, 11:24 am, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » December 31st, 2006, 12:14 pm

n1 Cliff

some wierd heavy cpu usage going on tho :( we're talking 99% in the initial minute xion is started
either with Xion not playing or playing, its using some resource either way in sporadic moments, atm on my system athy64 3200 its unusable, will try and play a little more with it

while checking out the pl/net mp3 issue
on first buffering title in pl and songticker says Connecting..., stayed like that due to the above issue
on second fetch it did connect and buffer the track
playing mp3 from net with spaces in title then %20 showing rather than blank space, also full url is displayed rather than track name, perhaps show full http path in playlist but use id tag title with url encode in songticker?


cant report on any more cos Xion just hogs cpu/system
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby SLoB » December 31st, 2006, 12:31 pm

hmm ignore my first post to some degree, deleted settings & states files
loaded up gbx & abducted and Xion is using zero-2% cpu as expected altho then loaded the current skin im working on and it goes to 99%

thers not that much going on in the new skin to warrant that behaviour

can pm u the skin, it was working in 64 with no issues which is why its bizarre
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby SLoB » December 31st, 2006, 1:03 pm

pm sent, hope that helps
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » December 31st, 2006, 1:31 pm

Issue was simply due to a large complicated skin attempting to redraw everything every frame. SLoB is aware of the issue with his skin and will be making the relevant changes to fix it. The build should be fine for all other users.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » December 31st, 2006, 1:37 pm

yep trans_netbuffer layer has now changed and on top of everything else, cpu usage has returned to normal, thanks Cliff :)
will make sure future skins use trans_netbuffer layer which is small and as near to the top of the pile as possible :) it was working with 64 but with the changes in 65 it didnt like it
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » December 31st, 2006, 2:08 pm

SLoB Wrote:yep trans_netbuffer layer has now changed and on top of everything else, cpu usage has returned to normal, thanks Cliff :)
will make sure future skins use trans_netbuffer layer which is small and as near to the top of the pile as possible :) it was working with 64 but with the changes in 65 it didnt like it


Actually I think the reason it probably worked in build 64 was that it was being displayed as full on, rather than full off which may have changed the logic for the dirty rectangle a bit. I will check.

If you'd like, check that it works on build 64 while you are listening to a netstream such as http://64.236.34.97:80/stream/1014

Theoretically it will perform in a similar manner with high CPU while the netbuffer layer is changing transparency.

I will look into why it thinks it is dirty when there is no netstream.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby KEV-O » December 31st, 2006, 2:43 pm

Looks great! Only issue I've noticed is that indi_mute doesn't seem to be working. (I'm using my ONE HUNDRED WATTS skin)
User avatar
KEV-O
Xion Admirer
 
Posts: 246
Joined: October 15th, 2006, 12:47 pm
Location: Kokomo, Indiana

Postby Cliff Cawley » December 31st, 2006, 3:10 pm

Ok, I've fixed the issue where Xion was thinking that the netbuffer layer was always dirty and causing the high cpu usage. I've updated the installer executable so if you're experiencing this problem, just re-download.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » December 31st, 2006, 3:12 pm

KEV-O Wrote:Looks great! Only issue I've noticed is that indi_mute doesn't seem to be working. (I'm using my ONE HUNDRED WATTS skin)


The reason for this is that the indi_mute layer in your skin is set to invisible. This means that by default it will be hidden until triggered by a modify event.

In previous versions, Xion would just automatically show this layer, which made it difficult to feature the indicator on hidden layers like slideout panels and the like. To fix it, you will simply need to set the indicator layer to visible in photoshop.

Sorry, I think I forgot this in the release notes.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby pickle » December 31st, 2006, 6:34 pm

Nice to see this release. It looks like it fixes a lot of pet peeves we've been having. The killer 9 track skin seems to be not so killer any more. Can't wait to give this baby a spin!

Any idea how close you're getting to releasing 1.1 Gold? I've got some skins I'd like to release, but they use stuff only found in the beta releases.

Nice work once again.
User avatar
pickle
Xion Admirer
 
Posts: 180
Joined: September 9th, 2006, 3:56 pm

Postby SLoB » December 31st, 2006, 11:37 pm

its wickedly quick now Cliff with no issues of stuttering during animations at least here anyways

is url encoding going to be added to songticker & pl paths?

did find a bug with the pl tho

open pl
add ->add url
paste into album textbox "Steve Vai Real Illusions:Reflectionssdfefsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdf
sdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfs
dfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsd
fsdfsdfsdfsdfsdfsdfsdfsdfsdfsd"
play above selection by double clicking or selecting then play
xion crashes with a buffer overrun

virtually any text with : is allowed but xion doesnt play it and moves onto the next proper track in pl as expected
not tried putting that into any of the other fields tho so it might happen on those too, also year is able to put in chars, shud limit to strictly 4 numbers

trans_netbuffer uses approx 40% cpu if using that layer at the bottom in 65 as per original, didnt check 64, so ive moved that layer as i had it last nite to fix it

on refresh F5
animation animtype(0) with a svst & paused keyword is still showing the next frame, in particular the layer at the bottom of that skin

animation animtype(0) id(lightscolor) delay(1) fadebetween svst paused

this is looping round on f5 yet the other animation set doesnt

all animation sets have paused keyword

thats all ive found so far, coming on nicely tho, keep up the good work Cliff :)
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » January 1st, 2007, 2:41 am

pickle Wrote:Nice to see this release. It looks like it fixes a lot of pet peeves we've been having. The killer 9 track skin seems to be not so killer any more. Can't wait to give this baby a spin!


Yes, I think I've optimized it to a point where multiple text layers no matters. Its possible there is no limit to the number you can have now, well...nothing close to 9 anyway ;)

pickle Wrote:Any idea how close you're getting to releasing 1.1 Gold? I've got some skins I'd like to release, but they use stuff only found in the beta releases.


Well I think I've added all the features I want for this next build. (there have been quite a few since the last release) Once I've squished all the bugs for this version, I'll most likely release one more beta and if everyone agrees, I'll make a new Release build ready for public consumption.

pickle Wrote:Nice work once again.


Cheers ;)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » January 1st, 2007, 12:23 pm

SLoB Wrote:open pl
add ->add url
paste into album textbox "Steve Vai Real Illusions:Reflectionssdfefsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdf
sdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfs
dfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsd
fsdfsdfsdfsdfsdfsdfsdfsdfsdfsd"
play above selection by double clicking or selecting then play
xion crashes with a buffer overrun

virtually any text with : is allowed but xion doesnt play it and moves onto the next proper track in pl as expected
not tried putting that into any of the other fields tho so it might happen on those too, also year is able to put in chars, shud limit to strictly 4 numbers


I've fixed all of these now, ready for the next build :)

SLoB Wrote:on refresh F5
animation animtype(0) with a svst & paused keyword is still showing the next frame, in particular the layer at the bottom of that skin

animation animtype(0) id(lightscolor) delay(1) fadebetween svst paused

this is looping round on f5 yet the other animation set doesnt

all animation sets have paused keyword


After much hoop jumping, I found that this is actually a logic error on your part! ;)

In your super special animation set that triggers the other sets 'animation animtype(0) id(colors) paused', you have set it to paused, but it pauses on the first frame, AFTER executing that acanplay for that frame, hence one of the animations is now out of sync. In order to fix it, just add a layer above that one with some nonsense text like 'donothing! :)'

Now when the set loads and pauses, it pauses on that first frame, but there is nothing to process so it just simply stops.

Does that make sense?

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » January 2nd, 2007, 2:59 am

oops :roll:, cheers Cliff :)
can you mention that in the reference chart so that if others try the animation set workarounds to trigger other layers/sets that they know about adding that donothing layer?
thanks
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK
Next

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest