Xion Audio Player

Xion 1.0 build 101 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » September 9th, 2008, 10:54 am

Barloggg Wrote:is there any way to receive track name/time for external application? perhabs most easy way is to copy track name (by use "track title format" sytax command) to window text. So you may change "xion" to this long string.


I will be making this available in the future :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby OfficerMike07 » September 9th, 2008, 11:27 am

Cliff Cawley Wrote:
SLoB Wrote:we must be due for another beta at some point Cliff? ;)


Indeed, its just taking a while to do the skinnable playlist :)

Cliff :)


For that, we'll wait patiently... we'd rather have it done right the first time around :wink:
User avatar
OfficerMike07
Xion Fan
 
Posts: 252
Joined: January 22nd, 2007, 12:36 pm
Location: A house, Lakeland, Florida, United States, North America, Earth, Milky Way

Postby OfficerMike07 » October 3rd, 2008, 1:01 pm

In the oscilloscope configuration window, the "More Blur" label is in the wrong place, occupying the same space as the slider, and disappearing when the slider takes focus.

Beta Build 101
Vista Home Premium SP1 32bit
User avatar
OfficerMike07
Xion Fan
 
Posts: 252
Joined: January 22nd, 2007, 12:36 pm
Location: A house, Lakeland, Florida, United States, North America, Earth, Milky Way

Postby Cliff Cawley » October 3rd, 2008, 1:30 pm

OfficerMike07 Wrote:In the oscilloscope configuration window, the "More Blur" label is in the wrong place, occupying the same space as the slider, and disappearing when the slider takes focus.

Beta Build 101
Vista Home Premium SP1 32bit


Heh cheers, I fixed this last night when I spotted it! You must have posted a couple of hours later. Thanks for mentioning, is fixed for the next build :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby OfficerMike07 » October 3rd, 2008, 2:09 pm

Cliff Cawley Wrote:
OfficerMike07 Wrote:In the oscilloscope configuration window, the "More Blur" label is in the wrong place, occupying the same space as the slider, and disappearing when the slider takes focus.

Beta Build 101
Vista Home Premium SP1 32bit


Heh cheers, I fixed this last night when I spotted it! You must have posted a couple of hours later. Thanks for mentioning, is fixed for the next build :)

Cliff :)


Hehe... I can't always beat the clock.
User avatar
OfficerMike07
Xion Fan
 
Posts: 252
Joined: January 22nd, 2007, 12:36 pm
Location: A house, Lakeland, Florida, United States, North America, Earth, Milky Way

Postby OfficerMike07 » October 3rd, 2008, 10:33 pm

The track title format help window is taller than my screen (1280*800) and doesn't have a scrollbar or seem to be resizeable. I cant read all of it!
User avatar
OfficerMike07
Xion Fan
 
Posts: 252
Joined: January 22nd, 2007, 12:36 pm
Location: A house, Lakeland, Florida, United States, North America, Earth, Milky Way

Postby SLoB » October 3rd, 2008, 11:26 pm

think its in a msg box atmor used to be, needs to be put into a non editable text box in the prefs with a scrollbar
you never know Cliff might have changed that by now?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby OfficerMike07 » October 4th, 2008, 2:36 am

SLoB Wrote:think its in a msg box atmor used to be, needs to be put into a non editable text box in the prefs with a scrollbar
you never know Cliff might have changed that by now?


He probably did change it... I was one day late on my last beta bug find.
User avatar
OfficerMike07
Xion Fan
 
Posts: 252
Joined: January 22nd, 2007, 12:36 pm
Location: A house, Lakeland, Florida, United States, North America, Earth, Milky Way

Postby Cliff Cawley » October 4th, 2008, 2:48 pm

Haha, no I didn't actually see this as its fine on my screen :P (1920x1200)

I'll look into changing the way its displayed. For a work around, if you're using XP and above, press CTRL+C on the message box window when its displayed, then click ok and open up notepad, then Paste it.

Cliff's Tip of the Week: In XP+ If you CTRL+C in a message box it will copy the text and allow you to paste elsewhere ;)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby OfficerMike07 » October 6th, 2008, 4:29 am

Today I tried to listen to a CD.

At first, I dragged the optical drive onto my Xion skin from My Computer. Songs wouldn't play automatically, and the only way I could get them to play was to open the playlist, click Control>Play, but once the song finished, I had to do the same thing to play the next track on the playlist. Same goes for adding my drive from the playlist's "Add Directory" option. Adding songs with through the playlist's "Add Files" option, however, allowed for normal functionality.
User avatar
OfficerMike07
Xion Fan
 
Posts: 252
Joined: January 22nd, 2007, 12:36 pm
Location: A house, Lakeland, Florida, United States, North America, Earth, Milky Way

Postby Cliff Cawley » October 6th, 2008, 7:46 am

OfficerMike07 Wrote:Today I tried to listen to a CD.

At first, I dragged the optical drive onto my Xion skin from My Computer. Songs wouldn't play automatically, and the only way I could get them to play was to open the playlist, click Control>Play, but once the song finished, I had to do the same thing to play the next track on the playlist. Same goes for adding my drive from the playlist's "Add Directory" option. Adding songs with through the playlist's "Add Files" option, however, allowed for normal functionality.


Thanks OfficerMike07, I'll have to investigate this one ;)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » October 7th, 2008, 3:19 am

I noticed this too when playing files off a hard drive.

It just fails to start the next song.

Also the crashes are becoming more annoying. Whenever i leave Xion to play my entire music folder overnight ( Music is good for my sleep, wipe that stupid smug off your face >.> ), i wake up in the morning to find it crashed dead or stopped by the next song start bug.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby OfficerMike07 » October 25th, 2008, 6:58 am

If the track title and track artist are on separate layers, the last artist played from the hard drive will not disappear from the "track artist" layer when switching from hard drive music to internet streams.
User avatar
OfficerMike07
Xion Fan
 
Posts: 252
Joined: January 22nd, 2007, 12:36 pm
Location: A house, Lakeland, Florida, United States, North America, Earth, Milky Way

Postby Cliff Cawley » October 25th, 2008, 11:21 am

logokas Wrote:Also the crashes are becoming more annoying. Whenever i leave Xion to play my entire music folder overnight ( Music is good for my sleep, wipe that stupid smug off your face >.> ), i wake up in the morning to find it crashed dead or stopped by the next song start bug.


When the crash occurs, which module is it in? Is it Bass.dll? I get this randomly too, hopefully with the next Bass Audio library update, this will be fixed.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » October 25th, 2008, 11:23 am

OfficerMike07 Wrote:If the track title and track artist are on separate layers, the last artist played from the hard drive will not disappear from the "track artist" layer when switching from hard drive music to internet streams.


Ah, thanks for finding this one OfficerMike07! Seems you've had your bug hunting hat on lately! ;)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia
PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron