Xion Audio Player

Xion 1.0 build 107 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » December 19th, 2008, 11:56 pm

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download Installer Version:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b107.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b107.exe

If you receive errors when running, install the VS2005 Runtimes
Download from Microsoft -> http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en

Changelist:
  • Fixed crossfading volume when you weren't using 100% volume - Thanks Jhirst!
  • Added support for automatic proxy settings through Control Panel -> Internet Options. If you setup a proxy here, Xion will use it when performing an Update check

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.


ABOUT THIS BUILD:

I still haven't received any feedback on the skinnable playlist! Has anyone out there tried to create their own? Has anyone made a playlist skin and found a bug?

The main changes for this build are the Update Check and Crossfading features along with the fix for Vista so that Xion skins now correctly download on Vista as .xsf instead of .zip. This is a semi re-release of 106 as I forgot to include the proxy connection settings. With 107 Xion will use the Internet Settings Proxy settings from your Control Panel. I also fixed a bug with the Crossfader. Let me hear your feedback! :)

Any questions or bugs related to this build should be posted here only!

Enjoy!

Cliff :)
Last edited by Cliff Cawley on January 11th, 2009, 1:46 pm, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Lance » December 20th, 2008, 12:25 am

Thanks a lot Cliff. I'm going to make a playlist RIGHT NOW. I will get back to with as soon as pos :)

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby Cliff Cawley » December 20th, 2008, 10:59 am

Lance Wrote:Thanks a lot Cliff. I'm going to make a playlist RIGHT NOW. I will get back to with as soon as pos :)

Peace, Lance


Thanks Lance! :D

Cliff 8)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Ilko » December 21st, 2008, 12:52 am

hey Cliff

is it possible to release the build 108 ?
User avatar
Ilko
Xion Supporter
 
Posts: 40
Joined: December 11th, 2007, 11:40 pm

Postby ALAS » December 21st, 2008, 3:19 am

cliff, first of all sorry there wasn´t more reply on the skinnable playlist from me... from some reasons I mentioned in another thread I decided to keep out of this discussion...

and since a few builds there are some things that confuse me...

I always get chaotic things happen in the playlist. sometimes it shows up, then parts of the default skin are mixed in there or huge parts of magic pink. The problem is this seems to be happening completely random, at least I couldn´t find out some ´rules´ of the bug, nor can I reproduce it always, all I know is it happens after loading a new skin... That´s why I didn´t mention that earlier...

another thing is that this ´over-states above other over-states´ thing you once reimplemented (you remember? ;) ) has also got mixed up since some builds. You know the technique I´m using e.g. in gamag, caruso and others of my skins. Again, I can´t find out when and why exactly :(

I know this isn´t much of a help but after all wanted to report that...


P.S. vista 32bit you know...
P.P.S. got that weired playlist phenomenon also on some XP comp...
User avatar
ALAS
Xion Fan
 
Posts: 256
Joined: March 12th, 2007, 3:26 am

Postby WinstonGFX » December 21st, 2008, 6:32 am

@ALAS: I'm running into the same issue with the playlist, seems to occur pretty randomly, I am about to test my hand at a custom playlist on a skin i am designing too

@Cliff: I have noticed a bit of a bug with making a Play/Pause button... my method worked on build 100, but in the last bunch of builds it would not work the same way (though I have figured out a workaround solution)
User avatar
WinstonGFX
Xion Admirer
 
Posts: 161
Joined: March 3rd, 2007, 6:47 pm
Location: Philadelphia, PA and New Jersey

Postby Lance » December 21st, 2008, 12:49 pm

Same here....
It's pretty much impossible to work on a a PL skin right now. It should be just as easy to drag the psd onto it once and just hit F5 to refresh like you do with the main player. But this isn't the case and along with the random mess that occurs, it pretty much renders it unskinnable! Hope you can sort this dude...

LOL, at least you have some feedback now :)

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby xonenine » December 22nd, 2008, 1:10 am

Im having the same issues w playlist building in that it works, but the ensuing playlist is very unstable. I'll try incorporating it into a zip and xsf and run it that way, with the skin residing in interfaces. xonenine :)

Every aspect of the playlist skinning works, when they are residing in a skin in xion. I think that most of the issues we're seeing are the result of not finalizing and installing the playlist in xion. If that extra step is necessary, it's no big deal, and makes sense that all the "errors" so to speak are being generated on the fly, as you can see many errors resolved on opening/closing playlist.
xonenine :)
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby Cliff Cawley » December 22nd, 2008, 8:58 am

So there are problems when dragging/dropping the PSD files? There are no problems if its zipped up?

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby xonenine » December 22nd, 2008, 9:31 am

The ones i zip and add to xion in a zip file work well, yes. The skins which are just drag and dropped seem to want to default to the default.
xonenine :)
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby Cliff Cawley » December 22nd, 2008, 1:32 pm

xonenine Wrote:The ones i zip and add to xion in a zip file work well, yes. The skins which are just drag and dropped seem to want to default to the default.
xonenine :)


Ok cool, I'll have to look into why that's happening! Shame I only found out now, you guys need to speak up more!! :P

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby xonenine » December 23rd, 2008, 12:49 am

I got a chance to work on pl some more, even the ones placed in interfaces folder often have to be set at least once manually by browsing to the pl skin.

Whichever pl skin was used last seems to stay in memory until changed manually, not necessarily the default skin.

It can't be a good thing that they're all named playlist.psd, would some kind of modified id tag help?

hope that helps, xonenine :)
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby pickle » December 23rd, 2008, 4:11 am

Crossfading seems to have a bug. Previous files aren't fading out when the current file is a net stream.

To reproduce:
  1. Play a file/stream
  2. In the playlist window, double click on a stream
  3. The new stream will start playing overtop the previous file/stream

This doesn't happen when going to a local file, only a stream. Stopping and starting playback removes the previous file & only the current file is played.
User avatar
pickle
Xion Admirer
 
Posts: 180
Joined: September 9th, 2006, 3:56 pm

Postby leadfoot » December 23rd, 2008, 4:21 am

I've been using 1.05 for a couple of weeks and just upped that to 1.07. With the Pure Adium skin (and skinned playlist), I'm using 8M of RAM. Just eight. The skinned playlist works perfectly, and the playlist sorting address one of the things that kept me from using Xion regularly.

Now, add album art, and I may have a new default player! (Yeah, I know it's on the wishlist, but I keep hoping. )
leadfoot
Xion Supporter
 
Posts: 27
Joined: March 4th, 2008, 11:59 am

Postby Cliff Cawley » December 23rd, 2008, 8:58 am

xonenine Wrote: It can't be a good thing that they're all named playlist.psd, would some kind of modified id tag help?


You don't need to call it playlist.psd, you can call it whatever you like. Xion will check for valid playlist tags when loading it from the Skin browser and if its a playlist it will send it to the playlist component.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia
Next

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest