Xion Audio Player

Xion 1.0 build 109 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » January 29th, 2009, 10:19 pm

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download Installer Version:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b109.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b109.exe

If you receive errors when running, install the VS2005 Runtimes
Download from Microsoft -> http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en

Changelist:
  • Fixed Album art not being properly refreshed when you reloaded the skin, or changed skins in between a song change
  • Fixed the loading process of Interfaces to allow better resolving now that there are two types, playlist and normal
  • Modified XionTagslib to better use File open for read, instead of attempting to gain full access immediately. This helps fix issues on Vista and Windows 7
  • Fixed loading of M3u files that contained mixed tag information. Some existing, some not - Thanks Luke!
  • Upgraded the minimum Win32 Compile flag to 0x0600 (vista/2008) as per the latest SDK. Open Dialogs now have proper Vista feel on Vista
  • Modified Xion to use the Documents and Settings folder if not a Portable build
  • Fixed potential crash due to XionWindow's not correctly deregistering when unloading components
  • Fixed the Taskbar Button menu. Disabled and removed commands that made no sense for the Xion windows
  • Improved support on Vista/Windows 7. Shouldn't have to run as Administrator any more.
  • Fixed the Crash Reporter so that it works correctly with Unicode. Also performed a couple of other minor changes and fixes.
  • Fixed loading of interfaces not in the Interfaces folder
  • Added a prompt for the user to copy existing files from the Interfaces folder, the first time they run under a new profile, if there are more than the default skin.
  • Added a 'Locate in Explorer' to the right click menu in the Skin Browser, allowing you to open Explorer to locate the skin
  • Fixed the Album Art in the playlist so that it correctly shows
  • Fixed the TriggerOn_SongChange for the playlist so that they correctly trigger
  • Added UAC Integration support. If you're not an Administrator and you attempt to perform a command that requires Admin, UAC will be invoked and the settings saved correctly.
  • Added UAC icons when not an Admin on Vista, Windows 7 and future systems.
  • Improved the File Types Config Tab Layout
  • Modified the List box drawing to allow for more items to be displayed in the config windows
  • Renamed GUI names for default plugins as well as internal plugin names
  • Added Associate All button to the File Types Tab
  • Modified the Hot Keys Disable All button to toggle between Disabling and Enabling all
  • Added hint text to the Global Hotkeys tab
  • Modified the Album Art layer so that its controlled by the skin and not whether the album art is valid or not. This fixes the usage of aclaswch, etc to control the album art visibilty
  • Renamed Default Plugin dlls to match the new internal names
  • Added auto cleanup of old plugins if they exist on install
  • Added relative path saving for the Portable version for current playlist, current filename, and current interfaces
  • Modified the way that File Types and other registry information is stored so thats its now all CurrentUser instead of Local machine.
  • Modified the MSN Playing text and removed Xion: and changed the format to be the same as other Media Players
  • Modified File Extensions to add an entry for OpenWithProgIds
  • Optimized the Shell notification process for Associate/Disassociate All
  • Added the ability to scroll a scrolling text layer with the mouse by dragging it
  • Fixed Cancel button on Shimmer Config Window
  • Modified default progress bar behaviour to make squabble sound when dragging. If you use the shift key it won't play till you release.
  • Fixed the Description for Hotkeys. Now when you enter Ctrl + Alt + Left, it will show that, instead of Ctrl + Alt + Num 4
  • Added support for new time layers. You can add the following new keywords (elapsed, remaining or total). These allow the skin author to control the time layer. If you don't specify any extra keywords other than time, it will default to user controlled.
  • Fixed the display of errors when a file is not found in a playlist
  • Added support for aclafadeto/action_layer_fadeto so that you can fade the alpha of a layer from one value to another

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.


ABOUT THIS BUILD:

This is a stabilisation build, heading towards the next Public release. I haven't had any reports of issues with the Unicode support, so it seems that was a success!

NOTE: All issues with Vista/Windows 7 should now be resolved! Please don't 'Run as Administrator' or 'Run in Compatibility' mode as there's no need to any more!

There'll be at least one more Beta build before Release. I want to polish off some existing features and fix any bugs from this build. Please test this build and let me know of any major issues! Thanks!

Any questions or bugs related to this build should be posted here only!

Enjoy!

Cliff :)
Last edited by Cliff Cawley on March 16th, 2009, 10:22 pm, edited 2 times in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby djinn2 » January 30th, 2009, 12:10 am

It all seems to be working well apart from a few little issues Cliff.

Xion installed over the old build (108) and asked to copy the interfaces to the Documents and Settings folder ok. This left the current interface referenced to the old location until it was manually changed.

Uninstalling Xion leaves a lot of file type entries behind in the registry, incuding those for playing the contents of folders from within explorer. These context entries work but cause an error dialog (error playing <path>).

Otherwise its great so far :D
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby logokas » January 30th, 2009, 1:39 am

Yay, i got my Associate all button!

All is well so far, it seems. Will keep you posted.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » January 30th, 2009, 7:52 am

djinn2 Wrote:It all seems to be working well apart from a few little issues Cliff.

Xion installed over the old build (108) and asked to copy the interfaces to the Documents and Settings folder ok. This left the current interface referenced to the old location until it was manually changed.


Actually, I'm ok with this one. If the file is then deleted, it will just load the default interface. The Program files location is just known as a 'Starting' location now.

djinn2 Wrote:Uninstalling Xion leaves a lot of file type entries behind in the registry, incuding those for playing the contents of folders from within explorer. These context entries work but cause an error dialog (error playing <path>).

Otherwise its great so far :D


Hmm did you register the file types with build 109 or a previous build?

I've changed registry locations for the file types so that its Multi user aware (I.e. each user can have their own associations). Its possible those old associations are still there from a previous version?

To test Disassociate all and then associate a couple of test ones. Now Uninstall and see if it correctly removes them. Its possible I didn't cleanup the old global Explorer settings though. I'll check it out and make sure its fixed for 110 :)

Thanks!

Cliff :)
Last edited by Cliff Cawley on February 3rd, 2009, 12:09 am, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » January 30th, 2009, 10:07 am

Had some fun with the errors.

Cliff, can you confirm two error reports to have arrived to you? You can probably tell that they're same by the config file.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby djinn2 » January 30th, 2009, 12:09 pm

Cliff, I did as you suggested and the context entries were still there when Xion was uninstalled so they must have been left overs. They could have been from any of the last few builds as I've just installed each build over the last (tried every build so far).

I'll leave everything as is for now rather than trawling through the registry. Besides it means any fix you come up with has a nice testing ground :wink:
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby Cliff Cawley » January 30th, 2009, 5:29 pm

logokas Wrote:Had some fun with the errors.

Cliff, can you confirm two error reports to have arrived to you? You can probably tell that they're same by the config file.


Hmm, nope don't have any reports yet :(
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » January 30th, 2009, 8:05 pm

In that case your reporter is not sending the reports as it should.

At any rate, i managed to crash the beta simply by using 'Play now in Xion' on the thing. Could be i triggered the leftover shell extensions.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby djinn2 » January 31st, 2009, 11:34 am

The playlist only displays the track times for tracks that have/are playing, this includes the total time at the bottom of the window. Has this ever worked with the skinnable playlist? I can't recall. Also 'refresh all track times' clears the times that are there and just reads the current track.
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby SLoB » February 1st, 2009, 6:10 pm

you should have got a few mails from the crash reporter from me too Cliff from build 108 i think, was amazed it kicked in after the other versions just crashed silently
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby Cliff Cawley » February 1st, 2009, 10:56 pm

logokas Wrote:In that case your reporter is not sending the reports as it should.

At any rate, i managed to crash the beta simply by using 'Play now in Xion' on the thing. Could be i triggered the leftover shell extensions.


Well the reporter should be using your email client to send the files. Did it do this? The address it sends it to should be the normal address. Check in your email client in the sent items, and potentially save the attachment to your desktop and use the Contact page here to send again.

I haven't received any emails about crashes so far :(
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » February 1st, 2009, 10:57 pm

djinn2 Wrote:The playlist only displays the track times for tracks that have/are playing, this includes the total time at the bottom of the window. Has this ever worked with the skinnable playlist? I can't recall. Also 'refresh all track times' clears the times that are there and just reads the current track.


Thanks djinn2, I'll have to look into this one and see where its going wrong.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » February 1st, 2009, 10:58 pm

SLoB Wrote:you should have got a few mails from the crash reporter from me too Cliff from build 108 i think, was amazed it kicked in after the other versions just crashed silently


Haven't got any from you either SLoB. Can you check your sent items too? And possibly send again on the Contact page?

If the email address is broken, let me know when you send an email to me on the Contact page. (Don't publish here)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » February 2nd, 2009, 7:12 am

Ew Cliff, e-mail client? Half the people don't use them. I'm one of those.

You should really provide something more universal for error reports instead of relying on extrernal software there.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » February 2nd, 2009, 12:51 pm

logokas Wrote:Ew Cliff, e-mail client? Half the people don't use them. I'm one of those.

You should really provide something more universal for error reports instead of relying on extrernal software there.


If it couldn't load your email client, it should have prompted you to save the file.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia
Next

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 6 guests