Xion Audio Player

Xion 1.0 build 115 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby xonenine » May 7th, 2009, 11:06 pm

Just wanted to say the error reporting additions are great! I got my first one for "layer mask applied".

I'm seeing a bug where if one track is in error, succesive tracks are all reported to be in error until I restart Xion. It hasn't been easy for me to reproduce yet, I will try to pin down the next time it happens.xonenine :)
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby Deathy » May 8th, 2009, 5:05 am

A suggestion more than a bug,
but the tray icon when you stop the player (the yellow one), isnt like the 2 others,
i mean, on the other, you have a outglow of 1 px i think and there is not on the yellow :)
Just a lil suggestion :)
Image
Deathy
Xion Supporter
 
Posts: 27
Joined: April 22nd, 2009, 4:29 am

Postby Cliff Cawley » May 9th, 2009, 12:12 am

Deathy Wrote:A suggestion more than a bug,
but the tray icon when you stop the player (the yellow one), isnt like the 2 others,
i mean, on the other, you have a outglow of 1 px i think and there is not on the yellow :)
Just a lil suggestion :)


Ok, I've updated the icon slightly to make sure its more similar to the other 2.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » May 9th, 2009, 5:39 am

Here's another bug for ya Cliff.

Spectrum Analyzer is deaf to streamed radio. Tested on a SHOUTCast stream, it doesn't output anything. Oscilloscope works fine.

EDIT: Oh and, some unicode characters are still incorrectly parsed.

Here, have a screenshot.

Image

Both bugs are visible. Well, in context.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » May 9th, 2009, 2:03 pm

logokas Wrote:Here's another bug for ya Cliff.

Spectrum Analyzer is deaf to streamed radio. Tested on a SHOUTCast stream, it doesn't output anything. Oscilloscope works fine..


Its just the skin you're using. There was a bug with the size of the spectrum that's been fixed for 116 :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia
Previous

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest

cron