Xion Audio Player

Xion 1.0 build 117 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » June 9th, 2009, 12:06 am

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download Installer Version:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b117.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b117.exe

If you receive errors when running, install the VS2005 Runtimes
Download from Microsoft -> http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en

Changelist:
  • Fixed the .xsk files not rendering previews correctly in the Skin Browser - Thanks Ilko!
  • Fixed the Bitrate not rendering correctly - Thanks Ilko!
  • Fixed the Playlist resizing incorrectly when it didn't have a snaprectangle defined
  • Fixed the Visualisation color appearing brighter when you several vis windows open - Thanks Jikaru!
  • Fixed the Skin Install dialog popping up when you browsed for a new skin in the plugin options screen and then cancelled - Thanks AphexMonkey!
  • Added an upgrade path for Hotkeys that now use the StringHash. This fixes losing Hotkeys when upgrading from a previous version
  • Fixed the default Toggle All Windows bind
  • Fixed the Library not loading previously added items correctly - Thanks Lance!
  • Added missing tooltip for Visualisation button - Thanks Rutabaga!
  • Allowed the user to bind to Alt+Key, however a Warning will be displayed that this may conflict with Menu systems
  • Added the ability to set an animation frame based on a slider. The new slider keywords are animframetb, animframebt, animframelr, animframerl. You will also need to use link(x) in order to link the slider to the animation that you want to control. Using a slider on an animation will also automatically pause it when you change the slider the first time. You may want to use the paused keyword on the animation layer.
  • Added a new readonly keyword for sliders. Use most useful for the animframe slider if you want to show a visual progress of the animation, but don't want the user to change the frame
  • Added double click support to the Default Visualation plugin. Double clicking the window will remove the frame and just leave a resizeable area. There is also an option in the Config window
  • Added support for a transparency slider using the following keywords: transtb, transbt, translr, transrl. The slider controls the transparency of a layer that it is linked to, using the link(x) keyword.
  • Modified the State Information structure to now save transparency information so that when Transparent sliders modify transparency of a layer, this can be saved out. This will cause any existing interfaces to rebuild their state. I.e. you'll lose any existing settings from skins that used save_state or svst such as color customization
  • Fixed the Crossfader not properly releasing the last track, meaning you couldn't move it physically on disk as it was still being used by Xion
  • Fixed the titlebar of the playlist from refreshing incorrectly when you are mass-adding files to the playlist
  • Modified the way that the Minimize function works slightly so that an internal visibility state is kept along side the state that windows uses, so that we can better sync the user's choice. Fixes issues with hotkeys and minimizing after a restart - Thanks Lance!

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.


ABOUT THIS BUILD:

Thanks to everyone who has been testing and reporting issues, getting really close now!

Crash reporter is again disabled. If there are crashes I'll make a new temporary build in order to reproduce. If not, we're all good.

Let me know if you find any issues! Also if everything is running smoothly then please let me know too! :)

Any questions or bugs related to this build should be posted here only!

Enjoy!

Cliff :)
Last edited by Cliff Cawley on July 5th, 2009, 12:16 pm, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Deathy » June 9th, 2009, 6:00 am

I don't know if this bug has been fixed for 117 but i report it again because i'm lazy :oops:

So, sometimes, when I start Xion, the main interface does not been displayed on my screen, and the most strange thing it's that when i double-click on the icon, the player don't appear. I must right right on the icon and select "Main Interface", strange?
Image
Deathy
Xion Supporter
 
Posts: 27
Joined: April 22nd, 2009, 4:29 am

Postby Cliff Cawley » June 9th, 2009, 8:09 am

Deathy Wrote:I don't know if this bug has been fixed for 117 but i report it again because i'm lazy :oops:

So, sometimes, when I start Xion, the main interface does not been displayed on my screen, and the most strange thing it's that when i double-click on the icon, the player don't appear. I must right right on the icon and select "Main Interface", strange?


I think this might be fixed. Is it possible that you minimized the player, then exited and when you loaded it again, the window was invisible? If so, yes this is fixed in 117 :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Jikaru » June 9th, 2009, 9:26 am

The visualization applied to the skin looks jittery, kinda square (dot and line on Oscilliscope), and still has the "start at dark then move to applied color" thing I mentioned last build.

When I have time I'll test out the new sliders as well.
User avatar
Jikaru
Xion Fan
 
Posts: 306
Joined: December 26th, 2007, 1:56 pm
Location: Orlando, FL, USA

Postby xonenine » June 9th, 2009, 11:52 am

Can't wait to use both the transparency and animation sliders, they both sound very straightforward too, thanks for such great documentation Cliff. :D

Edit: I'm finding that some skins still grey out the vis initially, then darken up nicely after a few clicks or switches of vis mode.. As for the blockiness Jikaru describes, I see that the slider for blur had defaulted to the highest setting, hence the blockiness. :)
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby AphexMonkey » June 10th, 2009, 12:50 am

Thanks for the new beta Cliff Cawley!!! :D
User avatar
AphexMonkey
Xion Supporter
 
Posts: 17
Joined: September 21st, 2008, 2:57 am

Postby Cliff Cawley » June 10th, 2009, 1:29 am

xonenine Wrote:Can't wait to use both the transparency and animation sliders, they both sound very straightforward too, thanks for such great documentation Cliff. :D


Hehe its not as full featured as I'd like, but at least you guys can get a running start ;)

xonenine Wrote:Edit: I'm finding that some skins still grey out the vis initially, then darken up nicely after a few clicks or switches of vis mode.. As for the blockiness Jikaru describes, I see that the slider for blur had defaulted to the highest setting, hence the blockiness. :)


Fixed for 118, thanks!

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » June 10th, 2009, 1:31 am

Jikaru Wrote:The visualization applied to the skin looks jittery, kinda square (dot and line on Oscilliscope)


Is this just the settings that have changed? Can you see if changing the blur helps fix?

Jikaru Wrote:and still has the "start at dark then move to applied color" thing I mentioned last build.


Fixed for 118.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby xonenine » June 10th, 2009, 9:43 am

Considering this to be sort of a beta issue, rather than a request:

I kind of wish when choosing a skin w/ a skinned playlist that the playlist wouldn't stay custom upon successive switches. Some of them are too glaringly different from default, I imagine this will always be true.
I guess it will no longer be an issue once more skins have playlists. :)

Also, I have no better idea what to do about it. :(
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY

Postby Jikaru » June 10th, 2009, 10:54 am

The jittering and the squaring might be the same problem?

The changing just feels very rapid now...wasn't like this before. before it was smooth and felt more like angular peaks.

Here's a screeny of the square-ness. Usually happens at the peaks and falls. Again didn't do this before. Oh and it has nothing to do with the settings as you can see it does this no matter what the settings.

Image
User avatar
Jikaru
Xion Fan
 
Posts: 306
Joined: December 26th, 2007, 1:56 pm
Location: Orlando, FL, USA

Postby Rutabaga » June 13th, 2009, 12:21 pm

I think this is a bug, unless I'm doing something wrong:

After resizing the height of the default playlist window, the bottom position for the slider seems to be calculated wrong. The slider doesn't make it to the bottom of the window, depending on the number of songs and how tall the window is (i.e. how many songs are visible).

Here at home, it is easy to see if you have > 30 songs loaded and resize the window to display all but ~5 of them. On my machine at work earlier today it was more pronounced; with 50 songs and ~30 visible, the slider would only go about half way down the window.

Also, I get a slightly different bottom position depending on whether I use the mouse scroll wheel, or I click on the slider and drag it down.
Rutabaga
Xion Supporter
 
Posts: 15
Joined: April 22nd, 2009, 1:33 pm
Location: Elkridge, MD, USA

Postby Jikaru » June 14th, 2009, 9:15 am

Rutabaga Wrote:I think this is a bug, unless I'm doing something wrong:

After resizing the height of the default playlist window, the bottom position for the slider seems to be calculated wrong. The slider doesn't make it to the bottom of the window, depending on the number of songs and how tall the window is (i.e. how many songs are visible).

Here at home, it is easy to see if you have > 30 songs loaded and resize the window to display all but ~5 of them. On my machine at work earlier today it was more pronounced; with 50 songs and ~30 visible, the slider would only go about half way down the window.

Also, I get a slightly different bottom position depending on whether I use the mouse scroll wheel, or I click on the slider and drag it down.


The skin your using needs to be corrected, the scrollbar should be like the default, if your using the default then it's a bug...but mine does not do this now, because it was corrected a few beta's back...when my XSe7en skin was being tested I had this problem and I had problems with spacing...but it was my fault not Xion's...so Like i said if it's the default skin acting like this then it's a bug but if it is a skin you made try and make the scrollbar longer on the bottom.
User avatar
Jikaru
Xion Fan
 
Posts: 306
Joined: December 26th, 2007, 1:56 pm
Location: Orlando, FL, USA

Postby Ilko » June 14th, 2009, 6:09 pm

when the cursor is over the limit of the playlist while doing a multiple selection, scrolling switches to auto mod :D

I know this bug since the build 100, now its said.
User avatar
Ilko
Xion Supporter
 
Posts: 40
Joined: December 11th, 2007, 11:40 pm

Postby Sinusoid » June 16th, 2009, 5:12 am

Rutabaga Wrote:I think this is a bug, unless I'm doing something wrong:

After resizing the height of the default playlist window, the bottom position for the slider seems to be calculated wrong. The slider doesn't make it to the bottom of the window, depending on the number of songs and how tall the window is (i.e. how many songs are visible).

Here at home, it is easy to see if you have > 30 songs loaded and resize the window to display all but ~5 of them. On my machine at work earlier today it was more pronounced; with 50 songs and ~30 visible, the slider would only go about half way down the window.

Also, I get a slightly different bottom position depending on whether I use the mouse scroll wheel, or I click on the slider and drag it down.


I can confirm this, and it does indeed happen with the default skin as well. I don't remember this bug occurring in the last build but maybe I just hadn't noticed.

The bug does not seem to occur for me as long as I have a fairly large number of songs in the playlist.
Sinusoid
Xion Supporter
 
Posts: 7
Joined: June 16th, 2009, 5:08 am

Postby xonenine » June 18th, 2009, 10:42 am

Well, just wanted to say the transparency sliders and svst both work terrific! These will be great to use instead of layers in alot of skins.Thanks Cliff. :D
User avatar
xonenine
Xion Freak
 
Posts: 873
Joined: February 8th, 2008, 1:29 pm
Location: NY
Next

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest

cron