Xion Audio Player

Xion 1.0 build 120 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby logokas » September 4th, 2009, 2:52 am

Actually, i used to get that, but it's gone now..

I don't know why. Must be a taskbar thing.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » September 4th, 2009, 9:02 am

Venom Wrote:ok.....here goes a long post.....
...idk if it's from Windows XP or not....or Xion bug....neither if it's that important...but....when i double-click Xion from tray a little thing appears(animation) on the left side of the screen...it's the type of animation like when you minimize a window....to the taskbar....but like i sayed it's on the left of the screen...and its only like half of the animation.....it's like a window would be on the left side of the screen that i can't see ...and when i 2xclick on Xion(tray) it minimizez.......ok......the thing is that i got a keyboard with multimedia keys(for Play/Pause/Stop/Next/Previous)....witch i can use with any video/audio player.....and in Xion..afther i 2xclick it the keys stop working for it......Ok....now..if i click again 2 times it comes back to normal....this time no animations...no nothing).....and the keys start working with Xion..........Idk if it's that big deal...but....for example i accidentali 2xclicked on it and I didn't knew wth happened with it cuz the keys stopped working for it.....
If u consider it's a important bug and wan't more details tell me and i'll try to make a video.
PS:Sorry for bad english and long post :shock: lol..
PS#2:Where can i put an profile image???i can't find any at 'Show gallery'...neither in IE 8 or Chrome..
---Thanx for reading--- :!:


Hi Venom,

I'll need to look into this again. I couldn't stop it from showing the animating minimizing window. Essentially you *are* minimizing Xion though, hence the reason it shows. Its not a good thing that the Multimedia keys don't work though!

I will see what I can do to fix this for the next build. Sorry for any confusion it has caused you.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Locomeister » September 6th, 2009, 12:44 am

The sound volume has variations during the playback.
User avatar
Locomeister
Xion Supporter
 
Posts: 3
Joined: July 7th, 2009, 8:01 am

Postby SLoB » September 6th, 2009, 12:59 am

could be your track rather than Xion?
Have you tried normalising the track then play it back through Xion?
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby dragoon » September 7th, 2009, 6:18 am

On the Xion default minimal skin, the small long-wise bar, when I click the countdown timer/song length a few times, Xion crashes. It happens every time.

Just play a song, set the skin, click the 00:00 next to the |> "Play" icon, should crash..
dragoon
Xion Supporter
 
Posts: 40
Joined: July 12th, 2008, 12:14 pm

Postby SLoB » September 7th, 2009, 7:23 am

Good find dragoon :)
Can confirm this issue by dragoon, on any skin click on the timer it does not switch to minus time, couple of clicks and bang its gone, just like cillit bang ;)
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby dragoon » September 7th, 2009, 8:12 am

SLoB Wrote:Good find dragoon :)


:P

Also, not really a bug but more of an annoyance. When adding a new skin to Xion, IE downloading and opening one from the website, Xion doesn't bring itself to the foreground. I have to minimize my browser and sometimes a few other windows to click in the small window and "install" the skin. Or is this just me?
dragoon
Xion Supporter
 
Posts: 40
Joined: July 12th, 2008, 12:14 pm

Postby djinn2 » September 8th, 2009, 7:39 am

Dropping an mp3 or a folder onto the main interface does nothing. I get the little "+" cursor but the track(s) don't load. Dropping files onto the playlist works fine. Occurs in Windows 7 and XP sp3. The context entries in explorer also work.

This was working in build 119, I double checked :roll:
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby cerberux » September 9th, 2009, 8:13 pm

Not sure if it's happened to anyone else, but my global hotkeys doesn't seem to save. I gets reset every time I close the program
cerberux
Xion Supporter
 
Posts: 18
Joined: August 31st, 2009, 12:12 pm

Postby vprimachenko » September 11th, 2009, 8:22 am

By me Xion reverts to default playlist skin every start
and it doesnt remember the size of playlist for various skins or so - my playlsit always renders broken into pieces - was not in 119 :?
vprimachenko
Xion Supporter
 
Posts: 24
Joined: August 29th, 2009, 7:49 pm

Postby Cliff Cawley » September 11th, 2009, 8:58 am

There's a bug in 120 that causes some settings to fail saving when you exit. I've fixed it for 121.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » September 11th, 2009, 9:06 am

djinn2 Wrote:Dropping an mp3 or a folder onto the main interface does nothing. I get the little "+" cursor but the track(s) don't load. Dropping files onto the playlist works fine. Occurs in Windows 7 and XP sp3. The context entries in explorer also work.

This was working in build 119, I double checked :roll:


Ah nice, I think its to do with the messaging changes, I'll get it fixed for 121, thanks!

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby SLoB » September 11th, 2009, 10:23 pm

Any sign of the beta version of the new default for build 121? It really needs at least 1 beta build imo to iron out any issues prior to full release, especially as the settings and playlist issues of recent bugs/fixes.
User avatar
SLoB
Xion Junkie
 
Posts: 1340
Joined: September 11th, 2006, 9:21 pm
Location: UK

Postby dragoon » September 12th, 2009, 10:43 am

Xion has become an unhealthy addiction :oops: I keep refreshing the Beta Builds forum a few times a day.. should I seek help?
dragoon
Xion Supporter
 
Posts: 40
Joined: July 12th, 2008, 12:14 pm

Postby Cliff Cawley » September 12th, 2009, 12:21 pm

SLoB Wrote:Any sign of the beta version of the new default for build 121? It really needs at least 1 beta build imo to iron out any issues prior to full release, especially as the settings and playlist issues of recent bugs/fixes.


Unfortunately there is bad news on that front. Lance sent me an email about a week ago, stating that he was sorry for the lack of contact, but that he would send me everything in the next 2 days. Well, unfortunately that never happened :( So I emailed him again and he's not responding again.

Instead of waiting it out for another 2 months, I've emailed him to say if I haven't got it within a week, I'll either take what he's sent me (beta main and playlist) and make the thin mode myself, or else I will need to find someone new to make the skin.

We'll see what happens, still no word from him and there are about 2 days left before the deadline. Hopefully he's just busy and he'll complete it this weekend (instead of last).

Cliff :roll:
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia
PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: Google Adsense [Bot] and 0 guests

cron