Xion Audio Player

Xion 1.0 build 121 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Monkeez » September 15th, 2009, 12:05 pm

I was just having a look through the PSD files for the new skin and I must say they are set out really nicely. Thanks for doing that Lance it'll really help me as a guide for making my own skins.

Cheers :P
User avatar
Monkeez
Xion Supporter
 
Posts: 7
Joined: June 23rd, 2009, 11:40 am

Postby Cliff Cawley » September 15th, 2009, 12:06 pm

I'll also put my vote in for liking the new longer bar mode ;)

Lance, perhaps for now, if you just swap the buttons from left to right, and right to left, then the Bar mode will be fine. We can then perhaps name it BarLarge, and make a second version that's quite a bit smaller by removing some controls? Not sure how much work that will be, we can always add a smaller bar mode after the public release.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Lance » September 15th, 2009, 1:04 pm

dragoon Wrote:EDIT: The playlist's new scrolling playlist name stays the same size even when the play list is made quite wide. Should this stretch to the side of the playlist? It looks strange just sitting in the middle between the menu buttons and the side.


This was mentioned in the Known Issues in the first post of the thread. It curently only scrolls but Cliff is implementing the text layer as a tileable element :)

As for critisim, this is exactly what we need. All feedback is good feedback :)

EDIT: Seen as people have voiced how they like the new Bar length, I'm also going to agree, I like it longer too. Personally I don't think it's all that long considering what's on it. I think a further more compact second Bar mode is the way this will turn out.

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby Lance » September 15th, 2009, 11:37 pm

djinn2 Wrote:The only issue with it is that the toggle equalizer button is brighter than the other buttons in the display. Design choice or oversight?


I was just reading through the topic again to make a list and came accross this. Honestly man, you're mistaken with that one! Every button in that row is the exact same, just the power of illusion coming into play here.

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby djinn2 » September 16th, 2009, 7:50 am

Then you too can share in my illusion Lance :D

Image
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby Cliff Cawley » September 16th, 2009, 8:57 am

djinn2 Wrote:Then you too can share in my illusion Lance :D

Image


Strange, they all look the same to me! What are you talking about djinn2???

:P

That's really interesting, is it like that when you restart? Or do you get it to look like that by doing something special? I wasn't able to reproduce here, as the only time its full white is when I hover over it.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » September 16th, 2009, 9:49 am

Equalizer is enabled. That's all there is.

EDIT: I just tried to do some file associations and context menu entry adding, and none of it worked. Vista Home Premium equipped laptop. Weird stuff is weird.

EDIT 2: Crossfade is active but appears turned off in my settings, wtf? Blaming it on saved settings bug, because the build i updated to 121 was pretty old, 11Xish.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Lance » September 16th, 2009, 11:41 am

djinn2 Wrote:Then you too can share in my illusion Lance :D

Image


Ah man, that means you have the equalizer switched on! Turn it off and it'll revert back to normal. Unless of course you want your EQ turned on :)

EDIT: I'm surprised Cliff didn't catch on to that either... :P

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby djinn2 » September 16th, 2009, 12:28 pm

That's cool. I didn't know about the indicator for the equalizer being enabled. You learn something everyday :roll:

It just goes to show what a good job you've done with this skin Lance to demonstrate all the cool stuff.
djinn2
Xion Admirer
 
Posts: 203
Joined: October 4th, 2006, 11:47 am
Location: UK

Postby Cliff Cawley » September 16th, 2009, 1:17 pm

logokas Wrote:EDIT: I just tried to do some file associations and context menu entry adding, and none of it worked. Vista Home Premium equipped laptop. Weird stuff is weird.


I know in Windows 7, you have to activate the file extensions in one of the control panels, is this the same on Vista? I.e. you enable in Xion, then you have to tell windows that you want Xion to look after your media.

logokas Wrote:EDIT 2: Crossfade is active but appears turned off in my settings, wtf? Blaming it on saved settings bug, because the build i updated to 121 was pretty old, 11Xish.


Hmm, I'll check it out, I think I just saw the same problem, I just can't reproduce.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Cliff Cawley » September 16th, 2009, 1:18 pm

Lance Wrote:EDIT: I'm surprised Cliff didn't catch on to that either... :P


Yah, I'm surprised too :|

Must be all these 2-3am nights I've been pulling to get Xion out :D

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » September 17th, 2009, 3:43 am

I noticed it first! I deserve credit D:
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Sinusoid » September 17th, 2009, 6:59 am

Aww nuts. This beta won't even start for me. I haven't seen anyone else complain about this so i'm sure i must have accidentally done something to the dll file it mentions... maybe?


anyways, here are all the details it reported:

Problem signature:
Problem Event Name: BEX
Application Name: Xion.exe
Application Version: 1.0.0.121
Application Timestamp: 4aae69ca
Fault Module Name: MSVCR80.dll
Fault Module Version: 8.0.50727.4016
Fault Module Timestamp: 49cc5361
Exception Offset: 00008aa0
Exception Code: c000000d
Exception Data: 00000000
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 1033
Additional Information 1: de8a
Additional Information 2: 4fa040a16f35e6e675984ea54b302855
Additional Information 3: 2d07
Additional Information 4: 5225acc6c0f4892c1259e47037015b14
Sinusoid
Xion Supporter
 
Posts: 7
Joined: June 16th, 2009, 5:08 am

Postby logokas » September 17th, 2009, 7:06 am

That's a visual basic related DLL. This probably means the dependencies aren't all clear afterall.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » September 17th, 2009, 9:05 am

Sinusoid Wrote:Aww nuts. This beta won't even start for me. I haven't seen anyone else complain about this so i'm sure i must have accidentally done something to the dll file it mentions... maybe?


anyways, here are all the details it reported:

Problem signature:
Problem Event Name: BEX
Application Name: Xion.exe
Application Version: 1.0.0.121
Application Timestamp: 4aae69ca
Fault Module Name: MSVCR80.dll
Fault Module Version: 8.0.50727.4016
Fault Module Timestamp: 49cc5361
Exception Offset: 00008aa0
Exception Code: c000000d
Exception Data: 00000000
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 1033
Additional Information 1: de8a
Additional Information 2: 4fa040a16f35e6e675984ea54b302855
Additional Information 3: 2d07
Additional Information 4: 5225acc6c0f4892c1259e47037015b14


a) Its not a Visual Basic Dll, its the Microsoft Common Runtimes. Has nothing to do with Visual Basic
b) If it was a dependency issue, it would have complained 'can't find dll blah'

The BEX Error is related to Data Execution Prevention.

I'm not 100% sure, but I think I may have fixed this for build 122 an I fixed a crash related to startup.

Sinusoid, I'll send you an updated interrum build to see if I've fixed it. If that still crashes, I'll build a version that reports the crash to me.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia
PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 5 guests