Xion Audio Player

Xion 1.0 build 122 Beta Release

Beta Builds of Xion. These are builds that are not quite ready for Release, but need feedback and bug submissions in order to move it to Release Status

Postby Cliff Cawley » September 22nd, 2009, 12:22 am

WARNING:
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download Installer Version:
r2 Studios Server -> http://www.r2.com.au/downloads/files/beta/qa-xion_v1.0b122.exe
OR
Xion Server -> http://xion.r2.com.au/download/beta/qa-xion_v1.0b122.exe

NOTE: Runtimes are now statically linked. You shouldn't need any external libraries! Let me know if it complains for you!

Changelist:
  • Updated the PSDReader to completely support loading groups of groups. You can now embed animations and groups in groups to your hearts content!
  • Added the new Xion icon into position 1 so that the windows shell will think the icon has changed and build us a new icon, without showing the old one that's in the IconCache.db
  • Force a ShellNotify if the Icon index for the FileType icons changes
  • Added nofadein, nofadeout, and nofade keywords so that you can control the fading when showing/hiding controls using the show/hide functions
  • Fixed crash on new installs when checking if we can refresh icons
  • Fixed a bug with loading/saving state when you loaded a pack, vs loading a single skin from the pack
  • Added complete support for Shared save state data. Shared data is auto saved when the xfer keyword is used in conjunction with the id() and svst
  • Fixed a crash if a borkerbk layer was specified, but not a borderT
  • Improved the meta data parsing from shoutcast and icycast servers
  • Added UTF8 parsing for Ogg stream tags (Fixed characters such as  showing up in some stream titles)
  • Added the ability to move up and down in the playlist by pressing up/down arrows while in the Search box
  • Forced the Search box to have focus when you show the Playlist window
  • Added the ability to quick search album, artist, title and genre in the Playlist. Consumes some more memory to do so
  • Modified the way that the Multimedia keys work, removing the need for the keys Hook DLL
  • Disabled the response of the Multimedia keys when you are assigning a Global Hotkey

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.


KNOWN ISSUES:
The new Default skin's Vis Left/Right buttons aren't finished yet, so won't currently do anything. Also, the Playlist Title text won't resize with the playlist. This will need some more code changes to fix properly and will be ready for build 122.


ABOUT THIS BUILD:

There are no changes to the Default skin for this build, waiting on some changes from Lance.

There are however a bunch of fixes, including hopefully, the final fix for the Multimedia keys. Hopefully they should be working for everyone this time and hopefully I don't need to revisit them again!

Any questions or bugs related to this build should be posted here only!

Enjoy!

Cliff :)
Last edited by Cliff Cawley on October 17th, 2009, 7:48 pm, edited 1 time in total.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Deathy » September 22nd, 2009, 12:52 am

My multimedia keys are working again, fixed for me!

PS: Xion is writted in C#,C++ or?
Thanks :)
Image
Deathy
Xion Supporter
 
Posts: 27
Joined: April 22nd, 2009, 4:29 am

Postby Cliff Cawley » September 22nd, 2009, 1:11 am

Deathy Wrote:My multimedia keys are working again, fixed for me!


Awesome :)

Deathy Wrote:PS: Xion is writted in C#,C++ or?


C++ using pure Win32 API calls. Why do you ask?

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby logokas » September 22nd, 2009, 1:47 am

Xion didn't shut down fast enough, so the installer produced an error message. I think a proper shutdown detection should be written into the installer instead of just putting in a delay.

Rest needs to be tested.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Cliff Cawley » September 22nd, 2009, 8:59 am

logokas Wrote:Xion didn't shut down fast enough, so the installer produced an error message. I think a proper shutdown detection should be written into the installer instead of just putting in a delay.

Rest needs to be tested.


Yup, I'll have to revisit it. I was using a third party plugin, so I might need to write my own to do the detection.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Deathy » September 23rd, 2009, 1:16 am

Cliff Cawley Wrote:C++ using pure Win32 API calls. Why do you ask?


Coz i'm learning C# at school, is Xion opensource? :)
Image
Deathy
Xion Supporter
 
Posts: 27
Joined: April 22nd, 2009, 4:29 am

Postby Venom » September 23rd, 2009, 3:39 am

why is the playlist so fat and ugly :(( the other one was very cool !!!
Venom
Xion Supporter
 
Posts: 14
Joined: August 19th, 2009, 2:05 am
Location: Romania

Postby Venom » September 23rd, 2009, 3:58 am

...and now my multi-media keys stopped working....wtf??.....I'm not playing my music in this....I'll take 1.20 untill a better release...
Venom
Xion Supporter
 
Posts: 14
Joined: August 19th, 2009, 2:05 am
Location: Romania

Postby Lance » September 23rd, 2009, 5:56 am

Venom Wrote:why is the playlist so fat and ugly :(( the other one was very cool !!!


Fat and ugly.... Hmm, not exactly the constructie feedback I was hoping for. But I'll take this as perhaps the PL is a little bulky and could be trimmed in some spots. On that note, I can now add that this is already on my list as a few people have said it can be shaved. I agree, so this will come for the public release.

Thanks for your feedback non-the-less.

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby Cliff Cawley » September 23rd, 2009, 8:59 am

Venom Wrote:...and now my multi-media keys stopped working....wtf??.....I'm not playing my music in this....I'll take 1.20 untill a better release...


Venom, seems that I fixed everyone else's keyboards, but now there's a problem with yours?

1) What type is it?
2) Have you installed the drivers for it?
3) Which version of Windows are you using?

I'd like to get it fixed, but I'll need some information from you.

Cliff
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Lance » September 23rd, 2009, 1:49 pm

Heh...he seems to have no problem saying he has a problem, but nothing towards helping us fix it.

But anyways, yeah, give Cliff some info. There's been a few people mention about media keys and such, always seems to be some kind of problem. I'm sure he'll get it fixed though. We don't bite, we just wanna make the best media player for the people. Whether that be correcting media keys or tweaking a fat ugly playlist ;)

Peace, Lance
I made the Xion Default skin. Ask me questions and stuff.

DeviantArt
User avatar
Lance
Xion Fan
 
Posts: 402
Joined: April 10th, 2008, 12:07 pm
Location: East Yorkshire, England

Postby logokas » September 23rd, 2009, 8:01 pm

Venom, being a Romanian and all, is just probably overly expressive with his words, Lance.

While i agree that the playlist might do with a little trimming, it's certainly not in the 'fat and ugly' category.
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Venom » September 23rd, 2009, 9:55 pm

hhhh......well....hi to everyone !...
......sorry for that short post with the problem...lol....i had 1.20 and jumped to 1.22(because the Xion was sleeping and didn't notice there is an update...like it usually does)...but,i also tryed 1.21....and i saw that there still is that....over-weight playlist :D....and the keys still don't work......also...i didn't give details about the multi-media keys not working , because i can't make it anymore clearer...THE KEYS DON'T WORK !....why?..don't ask me...take it this way....how come they work on 1.20??..and now not?....about the playlist....sorry for whoever designed it...but...the old one was way better..so congratz for the old one!..thumbs down for changing it!..at least let us choose from the 2 of them...u know...it's a prefference thing..some like shiny things...some like...u got the ideea.....
Logokas....being an Estonian u had to be the first one to have something to say about an onther nation no?
Cliff...respect !..and keep up the good work ! :wink:
1)Microsoft MultiMedia Keyboard 1.1
2)All drivers installed!
3)XP SP 3
---sorry for my english...aftherall I'm Romanian...right logokas?
Venom
Xion Supporter
 
Posts: 14
Joined: August 19th, 2009, 2:05 am
Location: Romania

Postby Cliff Cawley » September 23rd, 2009, 10:59 pm

Venom Wrote:1)Microsoft MultiMedia Keyboard 1.1
2)All drivers installed!
3)XP SP 3


When you say all drivers installed, did you install your keyboard drivers from here -> http://www.microsoft.com/hardware/downl ... ategory=MK ?

Also, is this your keyboard? -> http://www.dclstore.co.uk/images/produc ... 0007-l.jpg

I'm only asking because I need to try to reproduce it here.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Venom » September 23rd, 2009, 11:11 pm

It's ok if u ask...i want to help you in any way i can!...so..no..Cliff...the drivers(software) are from a CD.....and it installs IntelliType Pro 6.0.1(for kb) and IntelliPoint(for mouse)..and this is the exact picture Image
PS: I'm trying to update them...I'll come and post later if it works or not with 1.22 afther I update
RE:..updated the drivers and...now the |<< and >>| keys work but only when the playlist is displayed....but it instead of going to the next track it skips it and plays next one....the play/pause and stop still don't work..well...back to 1.20
Venom
Xion Supporter
 
Posts: 14
Joined: August 19th, 2009, 2:05 am
Location: Romania
Next

Return to Beta Builds

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron