Xion Audio Player

playlist help

General Discussion about Xion Audio Player

Postby logokas » December 13th, 2010, 1:39 pm

Does 127 not fix that issue?
I shoot and ask questions later.

Take no offense of it.
User avatar
logokas
Xion Addict
 
Posts: 668
Joined: February 25th, 2008, 8:44 am
Location: Estonia

Postby Pedobear » December 15th, 2010, 12:14 pm

logokas Wrote:Does 127 not fix that issue?


it does not :/
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby Cliff Cawley » December 15th, 2010, 10:52 pm

Just to clarify, which issue are you talking about? That you can't search for Album in the playlist? If that's the one, you can in build 127.

If not, please clarify :)

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Pedobear » December 18th, 2010, 7:53 am

Cliff Cawley Wrote:Just to clarify, which issue are you talking about? That you can't search for Album in the playlist? If that's the one, you can in build 127.

If not, please clarify :)

Cliff :)


yes the album one
i am still only seeing 1-3 songs for the album :(

here are some screen shots:
http://img232.imageshack.us/img232/5418/38932049.png (album In Silico)
http://img823.imageshack.us/img823/4279/17191235.png (album Immersion)
http://img840.imageshack.us/img840/8051/12280269.png (current 127 build)
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby Cliff Cawley » December 18th, 2010, 9:31 am

Pedobear Wrote:
Cliff Cawley Wrote:Just to clarify, which issue are you talking about? That you can't search for Album in the playlist? If that's the one, you can in build 127.

If not, please clarify :)

Cliff :)


yes the album one
i am still only seeing 1-3 songs for the album :(

here are some screen shots:
http://img232.imageshack.us/img232/5418/38932049.png (album In Silico)
http://img823.imageshack.us/img823/4279/17191235.png (album Immersion)
http://img840.imageshack.us/img840/8051/12280269.png (current 127 build)


That's really strange, I do exactly the same thing (I also have the immersion album from pendulum and it shows me the whole album).

Perhaps there's something going on in the tags. If you right click on any of the songs that don't show up, and choose 'View Song information' in the playlist, does the Album name show up correctly in the File Info window?

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Pedobear » December 18th, 2010, 10:48 am

Cliff Cawley Wrote:
Pedobear Wrote:
Cliff Cawley Wrote:Just to clarify, which issue are you talking about? That you can't search for Album in the playlist? If that's the one, you can in build 127.

If not, please clarify :)

Cliff :)


yes the album one
i am still only seeing 1-3 songs for the album :(

here are some screen shots:
http://img232.imageshack.us/img232/5418/38932049.png (album In Silico)
http://img823.imageshack.us/img823/4279/17191235.png (album Immersion)
http://img840.imageshack.us/img840/8051/12280269.png (current 127 build)


That's really strange, I do exactly the same thing (I also have the immersion album from pendulum and it shows me the whole album).

Perhaps there's something going on in the tags. If you right click on any of the songs that don't show up, and choose 'View Song information' in the playlist, does the Album name show up correctly in the File Info window?

Cliff :)


The tags are correct. I spent quite some hours managing my library a weekend ago. screenshot below. I have all my songs saved on 1 playlist (shouldn't affect anything right?)
Searching by Artist always works, its just them darn albums.

Also i think you have mentioned this before.
When i first add the entire album and save the playlist it will work via ablum. It's only after i quit xion and then start it up again that the album sort freaks out.

http://img816.imageshack.us/img816/2166/77072019.png

EDIT: could it be the format i have saved my playlist as?
does it make a difference if its .m3u8 or .m3u? (tested this, didn't affect anything)

I also reinstalled version 127 (cleaning up any old files left behind) still the same issue :(
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby Cliff Cawley » December 18th, 2010, 11:15 am

I'll do some more testing here, perhaps there's a bug that I'm not seeing due to the filenames. I name my files like: M:\Audio\Music\Pendulum\2010 - Immersion\08 The Island Pt.1 (Dawn).mp3

Maybe that's why I don't get the bug, because its picking it up in the filename instead. So when you first add the files, all the tags are read, but after loading from a playlist, that data isn't available yet till you play the file. The m3u format only includes whatever the title is.

Here's something to try, play one or two songs from that album, just play 1 second of them, then search again and see if the search now works.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Pedobear » December 18th, 2010, 11:22 am

Cliff Cawley Wrote:I'll do some more testing here, perhaps there's a bug that I'm not seeing due to the filenames. I name my files like: M:\Audio\Music\Pendulum\2010 - Immersion\08 The Island Pt.1 (Dawn).mp3

Maybe that's why I don't get the bug, because its picking it up in the filename instead. So when you first add the files, all the tags are read, but after loading from a playlist, that data isn't available yet till you play the file. The m3u format only includes whatever the title is.

Here's something to try, play one or two songs from that album, just play 1 second of them, then search again and see if the search now works.

Cliff :)


Right on the money Cliff. The second i play the song and search via album it is available! (however it is just that one song, if i play another song from the same album then both are available, etc.)

EDIT: out of curiosity, how do i upload my personal avatar?
I go to the control panel/edit avatar, however i don't see the option to upload my own (did some searching and found out why, some ppl :/)
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby Cliff Cawley » December 18th, 2010, 2:29 pm

Pedobear Wrote:Right on the money Cliff. The second i play the song and search via album it is available! (however it is just that one song, if i play another song from the same album then both are available, etc.)


Ok, I'll have to figure out a better way to do this. I'll either need to save the data to a database, or write it out as part of a new playlist format. One other option is to read in all the information over time in the background, but this will mean that searches will only work once the information loads in. If you have thousands of files it could take a little while before its all loaded.

Pedobear Wrote:EDIT: out of curiosity, how do i upload my personal avatar?
I go to the control panel/edit avatar, however i don't see the option to upload my own (did some searching and found out why, some ppl :/)


Yeah :( I'll enable again once I've pulled apart the phpBB code and fixed the bugs.

Cliff :)
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Pedobear » December 18th, 2010, 5:32 pm

can't wait!
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby Pedobear » April 8th, 2013, 4:01 pm

just wanted to bump this post (issue is still present in the latest 150 build).

i was really looking forward for this to be fixed :(

still a great release!
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA

Postby Cliff Cawley » April 22nd, 2013, 8:32 pm

This won't be fixed until I update the Library, sorry.
Cliff Cawley
Creator of Xion
r2 Studios
http://www.r2.com.au
http://xion.r2.com.au
User avatar
Cliff Cawley
Creator of Xion
 
Posts: 1955
Joined: September 3rd, 2006, 11:33 am
Location: Brisbane, Australia

Postby Pedobear » April 25th, 2013, 6:19 pm

Cliff Cawley Wrote:This won't be fixed until I update the Library, sorry.


any eta on that :O?
Pedobear
Xion Supporter
 
Posts: 26
Joined: November 27th, 2009, 4:18 am
Location: Shoreline, WA
Previous

Return to General Xion Discussion

Who is online

Users browsing this forum: No registered users and 1 guest