Page 1 of 1

Xion 1.0 build 83 Beta Release

PostPosted: July 7th, 2007, 5:08 pm
by Cliff Cawley
This is a Beta Build. That means it has fixes and features that are NEW. It is also possible it has bugs that are NEW! If you are looking for stability, please don't expect this build to be perfectly stable. It may have issues. If on the other hand you are happy to try this build out and post any bugs back in this thread, then please do!

Download Installer Version:
r2 Studios Server ->
Xion Server ->

  • Fix crash when xion is closed, playlist isn't saved, xion is started again, and playlist is cleared
  • Bail Zip if corrupt and clear Zip name on create
  • Update Bass_Vis to .0.7
  • Updates to fix size limitation of names and values in the data files
  • Add zlib to the Common folder
  • Modify MoveLayer function to update the Dirty rectangle correctly and to recalculate the width/height only at the end
  • Fix crash when reading a property such as fb that doesn't have fb(true)
  • Fix Volume jumping back up to full when you've set it to minimum using the interface
  • Add fix so that portable devices can install skins by dragging and dropping
  • Don't Update layers that aren't visible, such as vumeters and progress bars
  • Add check for 0 frame size to id3 checking
  • Add support for action_load_interface
  • Lots of Cleanup work in preparation for SDK
  • Increment the Component Version to 2
  • Fix detection of invalid Components and only allow update or Uninstall

If you find bugs specifically related to this build, please post them here instead of the Bug reporting forum. Any feedback positive or negative should also go in here, no new threads. This way all feedback, etc related to this build will be in the one place.

This build is mainly an update so that the SDK will function correctly with the Cleanup changes I made. You will NEED this build if you plan to develop Components using the SDK. You can find the SDK in the new SDK Beta Thread. There are also some new fixes in here as well as a new action called 'action_load_interface'


Cliff :)

PostPosted: July 26th, 2007, 6:41 am
by SLoB
some track layers are not scrolling when cd track is playing (they're stuck in limbo), net & local mp3/4/wma are fine and its instant to see when you switch to cd

now and again keep getting the 25% cpu usage but skin is doing nothing (not even playing) and no viz/animations looping, its strange cos it only happens once in a blue moon, will keep monitoring, only happens on p4 atm, cannot repro on athy64

btw as you know the example vis component compiles ok in 2003, will eventually get round to doing something heh :)